Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using fedora 18 with latest updates (kernel 3.10.12-100.fc18.x86_64, xorg 1.13.3).

Computer m/b has own vga connector, provided by:

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core 
processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])

And extra card, Radeon HD 7000, with two outputs.

xorg is configured to display to two 1920x1200 monitors via Radeon, and both are working ok. I'm using xfce.

Problem: I'm trying to add 3rd display, 1920x1080, connecting it to m/b vga connector.

3rd display shows computer bios startup messages, fedora boot options (kernel selection), then the small animated fedora logo, but when X should start, it shows only black screen with text:

[1.215074] [drm:drm_pci_agp_init] *ERROR* Cannot initialize the agpgart module.
[1.215668] DRM: Fill_in_dev failed.

at the same time, X starts correctly on two displays connected to Radeon, and all working ok on them.

my xorg.conf :


Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen      1  "aticonfig-Screen[0]-1" RightOf "aticonfig-Screen[0]-0"
    Screen      2  "intelvga-Screen[0]-0" LeftOf "aticonfig-Screen[0]-0"
    Option      "Clone" "off"
    Option      "Xinerama" "off"
EndSection

Section "Module" Load "freetype" Load "glx" Load "dbe" Load "extmod" Load "dri" EndSection

Section "ServerFlags" Option "AIGLX" "on" Option "AllowMouseOpenFail" "on" Option "IgnoreABI" "on" Option "ZapWarning" "on" Option "Xinerama" "off" EndSection

Section "Monitor" Identifier "aticonfig-Monitor[0]-0" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" EndSection

Section "Monitor" Identifier "aticonfig-Monitor[0]-1" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" EndSection

Section "Monitor" Identifier "intelvga-Monitor[0]-0" Option "VendorName" "Intel Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" EndSection

Section "Device" Identifier "aticonfig-Device[0]-0" Driver "fglrx" BusID "PCI:1:0:0" EndSection

Section "Device" Identifier "aticonfig-Device[0]-1" Driver "fglrx" BusID "PCI:1:0:0" Screen 1 EndSection

Section "Device" Identifier "intelvga-Device[0]-0" Driver "intel" BusID "PCI:0:2:0" Screen 2 EndSection

Section "Screen" Identifier "aticonfig-Screen[0]-0" Device "aticonfig-Device[0]-0" Monitor "aticonfig-Monitor[0]-0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection

Section "Screen" Identifier "aticonfig-Screen[0]-1" Device "aticonfig-Device[0]-1" Monitor "aticonfig-Monitor[0]-1" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection

Section "Screen" Identifier "intelvga-Screen[0]-0" Device "intelvga-Device[0]-0" Monitor "intelvga-Monitor[0]-0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 Modes "1920x1080" EndSubSection EndSection

share|improve this question
    
I tried adding video=efifb:off to grub kernel command line. Result was: X did not start at all. Segmentation fault. According to log, due to /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x41b8) [0x7ff23152ab48] –  user258807 Oct 1 '13 at 8:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.