Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I got the famous issue with Windows 8 context menu items. I've tried manually, with CCleaner, With Glary utility 3. And I still have some issues.

Here is an example for a right click on a .jpg:

Context menu .jpg

For the .jpg I can't seem to find any associations. Here is a SS from regedit HKEY_CLASSES_ROOT:

Regedit .jpg

share|improve this question
    
did you try updating your graphic drivers form device manager ? –  Fahad Saleem Oct 1 '13 at 9:32
    
@FahadSaleem it just tells me it's up to date. –  Warpzit Oct 1 '13 at 9:44
    
What exactly is the issue? What value do you have next to .jpg in (Default)? You should look that value up under HKEY_CLASSES_ROOT. –  Rik Oct 1 '13 at 10:05
    
@Rik In HKEY_CLASSES_ROOT/.jpg there is a (Default) with following value: IrfanView.jpg –  Warpzit Oct 1 '13 at 10:07
    
And what is the issue? Looks like your default program for .jpg is IrfanView. If something is wrong you can look in that key (IrfanView.jpg). (for me it says jpegfile) (I'm not familiar with what the famous issue with Windows 8 context menu items is) –  Rik Oct 1 '13 at 10:09
show 1 more comment

2 Answers 2

up vote 2 down vote accepted

The way the context-menus work is (simplified) like this:

You look in HKEY_CLASSES_ROOT for your file-extension (i.e. .jpg). It will contain a string value in (Default).

enter image description here

Sometimes you have all the information under this key. If not then you need to look up the value of (Default) in HKEY_CLASSES_ROOT (i.e. HKEY_CLASSES_ROOT/jpegfile).

enter image description here

There it will have all the context-entries you're looking for. You can edit them there.

share|improve this answer
    
I don't get why microsoft haven't made one place the user can go to easily change these settings. Lets say I wanted to change it for all images... That would take forever. –  Warpzit Oct 1 '13 at 12:11
    
They can't make it too easy. That's what programmers are for :) Kidding aside, they have made it so you can choose "Open with" and choose a different program (and if "Open with" is not there you can press shift and then right-click) but you're right, this has to be done per image-type. Normally this should be done by the program with which you want to associate it with (because it knows all the types it can support) but if things are screwed up you need to go digging (or re-install the application if it doesn't have a re-associate function). –  Rik Oct 1 '13 at 12:30
add comment

Try this

Open Registry Editor

Now navigate to this directory:

HKEY_CLASSES_ROOT\Directory\background\shellex\ContextMenuHandlers

enter image description here

Delete every folder in that directory except "New Folder"

Now Close the reg editor and see if it works

share|improve this answer
    
No results from this, but thanks for trying :) –  Warpzit Oct 1 '13 at 10:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.