Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a router that whenever it lost the connection it uses Permanently Moved (301) HTTP responses and literally I'm unable to access that link in Firefox. In Chrome/ium I can type the url then press Ctrl + Enter or opening the Developers Tool and disable the cache there in the options. Sadly, I haven't found a way which Firefox can imitate such behavior.

For now I'm appending ?a=1 at the end of the url to circumvent this problem, but is not desirable since if I click the url coming from another page I'll be in the same situation again.

EDIT: Private Browsing do some of this magic, but is actually Overkill for my proposes, since it kills the cookies.

What is Permanetly Moved (301) in the HTTP protocol?

For the answers/comments I'm getting seems that there is a misunderstanding of what is happening so I'm going to dwell more specifically in the topic.

Whenever I type http://superuser.com Firefox uses the cache (I can't press F5/Ctrl + F5 since I'm not in any page now) and see that the URL was Permanently Moved hence, it never goes to http://superuser.com but to http://deviceip/DeviceStatus_Warning.htm without delay nor stop. This question requires the understanding of both, the HTTP protocol and Firefox.

The HTTP response status code 301 Moved Permanently is used for permanent redirection, meaning current links or records using the URL that the 301 Moved Permanently response is received for should be updated to the new URL provided in the Location field of the response.

I doubt the "feature" can be disabled since it's a ISP modified firmware, but here it goes:

Maker: Huawei
Model: HG530
Software release: V100R001B025 Codetel
Firmware Release: 3.12.8.20

I have Telnet, HTTP and FTP access to the router, but I haven't seen anything similar:

TELNET commands available:

HG530> help
Valid commands are:
sys             exit            diag            ether             
wan             etherdbg        tcephydbg       ip                
bridge          dot1q           pktqos          show              
set             lan                                  
share|improve this question
    
CTRL+F5 will force a refresh on your cache in Firefox. –  Ramhound Oct 1 '13 at 13:58
    
The page is Moved Permanently, whenever I enter the link the url changes to the devices page. –  Braiam Oct 1 '13 at 13:58
    
This a new problem or has it always been a problem? –  Ramhound Oct 1 '13 at 14:50
    
It always been a problem whenever the internet gets unstable due the poor development of the router, anyone with the same router has this problem (and is the default router provided by the ISP, and you can't use anyone else). –  Braiam Oct 1 '13 at 15:03

2 Answers 2

up vote 1 down vote accepted

This is not the answer I'm looking for, since it should be integrated in Firefox, but! I would tell you what I ended up doing:

  1. I installed the FireBug add-on
  2. Before going to the page that is cached, I open Firebug and disable the cache in the Net tab.
  3. The cache is disabled, it means that it won't use, nor update, nor store any object in the cache (Firefox won't touch the cache) so I can go to the link.
  4. Enable the cache again, then press Ctrl + F5, now Firefox will get rid of the Cached Moved Permanently response.

I've opened a bug report about this, interested should go to:

https://bugzilla.mozilla.org/show_bug.cgi?id=923952

share|improve this answer

Go into private browsing mode.

Use this shortcut: command + shift + P.

share|improve this answer
1  
That kills cookies, and is something I don't actually want to. –  Braiam Oct 1 '13 at 13:56
    
In that case then do this.... You can force all requests relating to a refresh to actually be requested from the server (bypassing any already cached content, and updating the cache with the new version) by using Ctrl+F5 instead of just F5. This does not work for requests made by the page within client-side code though. When that is a problem you need to use the POST method (POST requests should never be cached) instead of GET or add an ever-changing value to the query string (such as the current time in ms). –  Ash M Oct 1 '13 at 13:58
    
Please, understand that the HTTP protocol don't allow me to do this. I type an url and before I could do anything it gets translated to my devices catch page. –  Braiam Oct 1 '13 at 14:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.