Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Even a few days ago everything was fine, but now simply I can't capture and see tcp, http, etc. wifi traffic but only the traffic for the protocols 802.11 and LLC. I used different wifi spots previously as well as now: none of them was changed somehow, there was no password added to them. What was changed is most probably the setting of wireshark but I really can't find out what exactly: I've tryied mix them up but there was no luck.

Also, when I start capturing the traffic in monitoring mode, I get disconnected after about 30 seconds and can't connect again until I turn off and turn on the WiFi card again. Although it seems a standard behaviour (I read about it), a few days ago it didn't occur at all.

What I can see in wireshark is only my local traffic. A checkbox Enable decryption is checked at settings->protocols->ieee 802.11.

What did change, how to get it back? Maybe I did something with my WiFi interface?

P.S. Yes, I saw the tutorial at wireshark website and Capturing wireless traffic (using Wireshark)

share|improve this question
    
What sort of access points are you connecting to? Are the APs you control and own or do they belong to someone else? If they are APs you own and control and have a legitimate reason to be sniffing, and nothing changed on them, then something changed on your computer. –  music2myear Oct 1 '13 at 17:42
    
@music2myear, that's what I said. –  Alex Oct 2 '13 at 0:53
add comment

1 Answer

You changed the Link-Layer Header Type in the Capture Options dialog. You set it to one of the 802.11 modes instead of "Ethernet".

On some (most? all?) Wi-Fi interfaces, you'll only see 802.11 types if you've checked the "Monitor Mode" checkbox. To see the "Ethernet" type as an option on the "Link-Layer Header Type" pop-up menu, you may need to un-check the "Monitor Mode" checkbox.

share|improve this answer
    
it seems to work, let me check it more carefully. –  Alex Oct 2 '13 at 0:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.