Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed Ubuntu 9.10 on my laptop with an i915 Intel integrated graphics card, and OpenGL is now extremely choppy. However, the overall performance is better. On 9.04, I got ~800 FPS on glxgears. Now I get ~3000 FPS!

I only have this problem with Compiz enabled. However, Compiz itself is not choppy at all (and it uses OpenGL).

Everything was working fine on 9.04 with UXA/DRI2 enabled.

Does anyone know what is wrong and how to fix it?

share|improve this question
    
could the choppyness be a 'tearing effect'? If so (I am just grasping at ideas here) could be vertical sync needs to be enabled? –  Jakub Dec 23 '09 at 13:22
    
@Jakub: No, I don't think so. It was stuttering, not tearing. However, it doesn't seems to happen any more. An update must have fixed it. It works fine with Compiz now, but KWin still doesn't work. –  Zifre Jan 3 '10 at 20:18
add comment

1 Answer 1

up vote 2 down vote accepted

Disable Visual Effects. It's probably not what you want to hear, but it works.

share|improve this answer
    
Well, I don't like that solution, but I'm using it for now. I would be very happy if somebody had a proper solution... –  Zifre Nov 4 '09 at 1:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.