Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


Don't waste your time with MacPorts. I would recommend using Homebrew instead. It's easy to use and doesn't clutter up your system with a bunch of junk directories.

Update: Don't install Darwin Ports. Darwin Ports is a fake. Also, I did not have a great experience using MacPorts, so I don't recommend using it.

Original Question:

So I decided to download and install Darwin Ports to make my life a little easier. I ran the installer and it seemed to install just fine. But when I run sudo port -d selfupdate like the documentation says to do, I get some sort of message:

 dlopen(/opt/local/share/macports/Tcl/pextlib1.0/Pextlib.dylib, 10): no suitable image found.  Did find: /opt/local/share/macports/Tcl/pextlib1.0/Pextlib.dylib: no matching architecture in universal wrapper while executing "load /opt/local/share/macports/Tcl/pextlib1.0/Pextlib.dylib" ("package ifneeded Pextlib 1.0" script) invoked from within "package require Pextlib 1.0" (file "/opt/local/bin/port" line 40)

I don't know what that means or what I should do. Any suggestions? I also don't know the difference between Darwin Ports and MacPorts. Maybe I am trying to install the wrong thing?

Update: I decided to install MacPorts to see what would happen. I was able to download the version of the MacPorts package installer for Snow Leopard, install MacPorts and run sudo port -v selfupdate (note the -v difference) and get it to update correctly. Now I am trying to install phpMyAdmin by doing sudo port install phpmyadmin but I get this error message:

--->  Computing dependencies for phpmyadmin
Error: Unable to execute port: can't read "build.cmd": Failed to locate 'make' in path: '/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin' or at its MacPorts configuration time location, did you move it?

Did I miss a step in installing MacPorts?

Update: Turns out I needed to re-install the newest version of Xcode.

share|improve this question
Please note that is bogus. See the DarwinPorts History page at MacPorts. – Chris Johnsen Nov 8 '09 at 7:10
A suggestion from my experience: be careful with MacPorts. I don't know what specifically you're going to use it for and what I actually did to cause this, but using MacPorts managed to hose my python installation. I had something like 3 interpreters in various locations all at different versions and all only having some of my libraries installed. It was a mess, and that's why I try to stay away when possible. ./configure && make && sudo make install isn't particularly difficult most of the time. – user12764 Jul 9 '10 at 4:15
Try fink. I've had much better luck with it. – asmeurer Jun 22 '12 at 8:22
up vote 5 down vote accepted

Have you installed XCode before? My make is in /usr/bin so I think it’s got nothing to do with Macports itself but must be supplied by other means.


According to this macports ticket you might have two options. First you could check, whether make is in /Developer/usr/bin. If so, you could enable the binpath in /opt/local/etc/macports/macports.conf and add this path to it. (Though using the binpath explicitly is flagged as advanced in the file.

The other option is, of course, reinstalling XCode. And this time be careful to select ‘Unix Development Support’ while you’re at it. There’s a chance that you’ve missed this when installing it the last time.

If make has gone missing for some other reason, there might be something pretty wrong with your system, so it’s better to assume that it’s never been installed before…

share|improve this answer
I'm pretty sure I have XCode installed and running correctly. – Andrew Nov 4 '09 at 1:15
"Pretty sure" or absolute sure? You have to have XCode installed for MacPorts to work (it uses some components installed with XCode). – mipadi Nov 4 '09 at 1:51
ok...Absolutely Sure. I have already installed Xcode and have used it before. I have even opened it after upgrading to Snow Leopard to make sure it still worked. Though, there's nothing in /usr/bin called make – Andrew Nov 4 '09 at 5:51
@misbehavens I am pretty sure that you need Xcode 3.2 with Snow Leopard (install it from your Snow Leopard DVD, or download it from Apple via a free ADC account). Any older versions will probably break in one way or another. – Chris Johnsen Nov 4 '09 at 6:33
Okay...just installed Xcode 3.2 and now make shows up in /usr/bin – Andrew Nov 7 '09 at 19:51

I got mine working after following this site -

share|improve this answer

I solved this problem by installing MacPort (1.8.2) using source code. Not sure how it works though.

The MacPorts Project is an open-source community initiative to design an easy-to-use system for compiling, installing, and upgrading either command-line, X11 or Aqua based open-source software on the Mac OS X operating system. To that end we provide the command-line driven MacPorts software package under a BSD License, and through it easy access to thousands of ports that greatly simplify the task of compiling and installing open-source software on your Mac.

We provide a single software tree that attempts to track the latest release of every software title (port) we distribute, without splitting them into “stable” Vs. “unstable” branches, targeting mainly the current Mac OS X release (10.7, A.K.A Lion) and the immediately previous one (10.6, A.K.A. Snow Leopard). There are currently 15361 ports in our tree, distributed among 98 different categories, and more are being added on a regular basis.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .