Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was always just one click away from the translator, image search etc..

Here is how it was:

enter image description here

Now I need to click on the small icon on the right and scroll down, because the translator is for some reason hidden at the end of the popup window and you need to scroll.

It's very unergonomic.

It's like removing the gray top bar with your points, link to your profile and other link on Stackexchange websites.

How to get the black bar back?

What are my possibilities? Any browser plugins/extensions?

I am using Chrome and Firefox, so i would prefer solutions for these two browsers if possible.

share|improve this question
1  
You probably mean the bookmarks bar? I'm almost sure it's because you have too many bookmarks and those that won't fit will get into the dropdown at the end. You need to clean up your bookmarks, or put the links you use more regularly at the front. –  Jerry Oct 2 '13 at 6:23
    
Bookmarks bar is black? like background-color: black; ? –  Derfder Oct 2 '13 at 6:35
    
Seems to me that the Powers That Be at Almighty Google have decided that This Way Is Better, and you just have to deal with it. Google's been doing this a lot lately. –  tjennings Oct 2 '13 at 6:49
    
Oh that! I'm afraid you can't change it. I don't even use 'Play', 'Maps' or 'News'. Just send a complaint feedback to google I guess for what's worth. Otherwise, I usually just type 'tr' in the address bar and I get the google translate link first. –  Jerry Oct 2 '13 at 6:55
    
@Jerry no google chrome extension that can emulate this? –  Derfder Oct 2 '13 at 7:11

2 Answers 2

You probably have the new Google-Homepage.

If you want the old home-page back you can try the following (this only works in Chrome):

  • enter chrome://flags in the address bar
  • goto Enable Instant Extended API
  • Set it to Disabled
  • Restart Chrome

This worked for me (until Google decides otherwise).

Edit: If you go directly to chrome://flags/#enable-instant-extended-api you don't have to search :)

Edit 2: If that does not work you can do the following (this also worked for me in Firefox with mixed results):

If that does not work you can do the following:

  • Go to your www.google.com

  • Type in javascript: and paste the following in the addressbar after it and press enter:

For the old black bar menu: document.cookie="PREF=ID=5b4ad955416c1d63:U=c5badcc79f7fa108:FF=4:LD=en:NR=20:NW=1:TM=1374684101:LM=1380247074:GM=1:SG=2:S=B6lEsMB1Hk9d6zjs ; path=/; domain=google.com";window.location.reload();

For back to the new menu: document.cookie="PREF=ID=e66a207a51ceefd8:U=936bafc98b2a9121:FF=0:LD=en:NR=10:CR=2:TM=1378808351:LM=1379592992:SG=1:S=OXyq0fqClYB66VuV ; path=/; domain=google.com";window.location.reload();

Note: you can't paste a javascript:xxxx line so you have to manually type javascript: and paste the given lines after it.

If it doesn't work on the home page (www.google.com) then first go to Google+ and do it there.

Edit 3:

Wow, this is really annoying. Above method (Edit 2) sets a cookie for google.com but sometimes Google decides to mess with that cookie. My latest solution is making a shortcut in the bookmark-bar to the javascript code and everytime Google changes it back to the new page I press it so I get the old black-bar page back.

In the bookmark you can type Black bar as name the following as url:

javascript:document.cookie="PREF=ID=5b4ad955416c1d63:U=c5badcc79f7fa108:FF=4:LD=en:NR=20:NW=1:TM=1374684101:LM=1380247074:GM=1:SG=2:S=B6lEsMB1Hk9d6zjs ; path=/; domain=google.com";window.location.reload();

(upside to Edit2 is with a bookmark you can specify javascript: in front so you don't have to type it every time)

Edit 4: I can't make a link here which you can drag so do the following:

  • Goto Google
  • Drag the icon (in front of the address-bar to your bookmark-bar
  • Right-click the bookmark and click Edit
  • Change name in Black bar
  • Change URL in javascript:document.cookie="PREF=ID=5b4ad955416c1d63:U=c5badcc79f7fa108:FF=4:LD=en:NR=20:NW=1:TM=1374684101:LM=1380247074:GM=1:SG=2:S=B6lEsMB1Hk9d6zjs ; path=/; domain=google.com";window.location.reload();
  • Now click the bookmark and the black bar should re-appear on the page

At this time I'm getting very mixed results myself. First it worked and I went to Google+ and it was gone. Now a second time it doesn't work. Make sure you keep on Google.com and don't switch to a local page from Google. You need to make sure all Google cookies are deleted. (Goto Settings, click Advanced settings. Content settings, All cookies and site data, type google in the search box and choose Remove all.

share|improve this answer
    
Thanks, I will try that and let you know if it works. –  Derfder Oct 2 '13 at 11:25
    
Well, as of right this moment (Google switched me again), the first method (chomme://flags) doesn't work for me anymore. Just did the javascript: line and that worked (for now). –  Rik Oct 2 '13 at 21:50
1  
If you keep getting the new page back... see my Edit 3 :) But I'm beginning to believe Google won't be keeping the black bar for long. –  Rik Oct 3 '13 at 20:35
    
THis is n't working for me ;(. COuld you make a tutorial, maybe I am doing something wrong. –  Derfder Oct 4 '13 at 13:21
    
I'm getting really mixed results myself. One time it works and the next not. I added a small tutorial but I need to dig deeper as to why it's working one time and the next not. –  Rik Oct 4 '13 at 13:53

You might try using the Chrome extension Big G Black Bar Sorter to rearrange or add Google services to the navigation bar.

Once you've installed it, you can even add new custom links at its website.

Read also this lifehacker review : Big G Black Bar Sorter Customizes Google's Black Bar to Your Liking.

Another fix found on the Internet is :

  1. Open a new tab in Google Chrome
  2. Copy and paste the following into the Chrome omnibox (the URL bar) and hit enter: chrome://flags/#enable-instant-extended-api
  3. Turn off the ‘Instant Extended API’ by clicking the drop-down menu and selecting the Disable option.
  4. Click the Relaunch Chrome button that appears towards the bottom of the window.

And yet another fix is to use the following link https://www.google.com/webhp?complete=0&hl=en.

You can also try to use the old home-page that Google still keeps for use as the Firefox home-page.

Just remember that a fix that works today may not work a few months after. The Google page is always changing.

share|improve this answer
    
You can even drag the Translate dropdown menu item into the menubar. Nice! –  sdelmas Oct 7 '13 at 22:45
    
@harrymc: your given link worked for me but unable i am unable to get auto suggest by Google and also in chrome it is not working means it is giving error as Incorrect certificate for host. –  Anand Jaju Oct 8 '13 at 5:18

protected by Community Oct 3 '13 at 8:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.