Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My linux server can not resolve some domains. I have to restart NAMED service to fix it. Is there any permanent solution for this?

share|improve this question

migrated from Oct 2 '13 at 10:11

This question came from our site for professional and enthusiast programmers.

Yes, make sure you have a DNS server set up that your server can see. – Oliver Charlesworth Sep 25 '13 at 7:10
Stackoverflow is for help with coding. Questions on infrastructure are best posted to Serverfault. – Arjun Sol Sep 25 '13 at 7:10


1), Make sure the domains you needed is configured in your BIND's named.conf;

2), Make sure your named.conf is correct, using named-checkconf to check configuration, or ask for bind's log for correction;

3), Use dig @your_named_ip your_domain to see if your domains can be resolved;

4), if 3) is correct, add nameserver your_named_ip into your linux server's /etc/resolv.conf.

share|improve this answer
up vote 0 down vote accepted

named and bind service are used for dns resolution, so you have to start them to resolve the domains from your linux server. The permanent solution is to keep the named service on at any runlevel. You can achieve this by the following command :-

$ chkconfig named on

Thanks & Regards,
Alok Thaker

share|improve this answer
Hi.Thanks for your reply. but the service is always on. and this will not happen to every domains. for example, domain is not resolving. so i have to restart named service to fix it. some hours later, this will happen again and is not resolving. – behzad safamanesh Sep 25 '13 at 7:22
If you are not able to resolve some of the domains then you can keep your dns to google public dns in /etc/resolv.conf as nameserver and nameserver You can also check with your ISP that why some of the domains are not getting resolved too. Do you have a router whose DNS you are using then check the router dns settings are correctly set as per ISP or ask them for support. – linux_fanatic Sep 25 '13 at 7:36

You must log in to answer this question.