Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I currently have a Netgear ADSL modem/router connected to the telephone master socket, which has DHCP enabled. I then have a wired connection to an Apple Time Capsule in Bridge Mode, which is a wireless access point for one end of my house, then, via a long, wired connection at the other end of the house (few other devices and switches along the way) is an Apple Airport Extreme in Bridge Mode, which is my wireless access point for the other end of the house. Both of these apple devices have the same SSID and passwords, so they are automatically switched between when walking from one end of the house to the other with any wireless phones, tablets etc.

Recently I have noticed that we've been getting a few IP conflicts (another device on this network is using the same IP Address) which I can't figure out, as the DHCP pool I have given on the Netgear is from 192.168.0.100 - 192.168.0.254. There are no static ip's allocated on the network that fall within this range. Any static ip's that are allocated to a few machines are between 192.168.0.1 - 192.168.0.90.

We have about 10 'wired' devices on the network that use DHCP and probably about 7 or 8 wireless devices that use DHCP.

So I'm wondering what might be the cause of the occasional IP conflict message (which ends up with me usually rebooting the netgear which sorts things out), and what might be a way around it?

I started playing with the Apple Time Capsule, changing it from Bridge Mode to DHCP & NAT mode, and disabling DHCP on the netgear, as the DHCP on the Time Capsule offers a couple more options than the netgear (things like lease time etc), but when I did that, it started giving warnings of Double DHCP etc, even though I'd turned off DHCP on the netgear, so for now I've reverted back to the original configuration above.

share|improve this question
    
From my understanding, only one DHCP router can assign addresses on a network. Shut off DHCP on ALL routers except 1. See Ecnerwal's answer below. I am sure there are ways around this, but an easy fix would be to only have 1 DHCP router. –  Damon Oct 3 '13 at 4:44
    
There is usually no real benefit from doing so, but you can have two (or more), and have it work, so long as they don't overlap (ie, one gives out 192.168.5.100-150 and the other gives out 192.168.5.151-200) and both give out the correct gateway. Typical consumer router gear tends to hand out itself as the gateway, which is fine when it's the router, not fine when it's not. Some can be set correctly if they are not it, some cannot. –  Ecnerwal Oct 3 '13 at 17:20

4 Answers 4

Something else is offering DHCP.

Try turning off DHCP on the netgear while leaving it off on the ATC and see if you still get an address. It would appear from your symptoms that you might. Then you can track down what's doing that...

share|improve this answer

I have the exact problem, and I have found the problem seems to be a bug in Apple Time Capsule. My Time Capsule was originally a DHCP server for the 102.168.0.x range, with DHCP switched off on my Netgear modem. Unfortunately, I could not find a way to switch off NAT on the modem, so I ended up with the 'Double NAT' problem on the ATC. So I switched DHCP on on the modem, and turned ATC into Bridge mode. But I found that the ATC was still serving DHCP addresses to any wireless clients instead of passing them back to the modem. The solution was to switch the ATC back to DHCP/NAT mode and select a DHCP range NOT on the modem/router's subnet (e.g. 192.168.10.x). Restart the ATC, and then go back and switch it back to Bridge mode, and bingo - no more rogue DHCP! I suspect that the ATC 'remembers' its last-set DHCP settings and tries to serve them on the subnet even when in Bridge mode.

Hope this helps - good luck!

share|improve this answer

Try to keep the DHCP enabled on Netgear ADSL modem/router and disable the DHCP on other router. You can keep the other routers in either BRIDGE or SWITCH mode. Assign static IP on other routers and make sure that the assigned IP is not assigned to any other device connected with Netgear ADSL. Hope this can fix your issues. Also for making Apple Airport Extreme router to work in BRIDGE mode connect the output cable from Netgear to the output port of Apple Airport Extreme router.

share|improve this answer

Disable DHCP on both the ATC and the Netgear, fire up wireshark or tcpdump and then release your address and watch for DHCP offers.

My bet is you've a rogue DHCP server on your network, it could be as simple as someone having internet connection sharing enabled on a laptop that they use with 3G on the road.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.