Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Power went off. When I rebooted I started receiving unmountable_boot_volume on windows loading screen (that is windows started loading progress bar and all, then stopped, kept trying to read some file in the drive audibly failing (blip pause blip pause etc) then BSOD with 0x000000ED). Formatted a usb stick (no cd rom drive) and added the Hiren´s Boot Cd, tried booting into "mini XP" - same blip blip bang.
What I make of it is some system file needed on boot is corrupted - the drive is not, I run chkdsk via Hiren's btw and I can also (dual) boot to linux (a horrible frustrating xandros distro I won't say more about) that's preinstalled.

My question : how can I, via hirens, locate and bypass the problematic file ? Do I need the original XP cd (I have it shipped from home but should be an older SP, I am on SP3) ?

EDIT : needless to say tried rebooting 20 + times, same behavior - the drive is not dying - just a particular failure. chkdsk reported no bad sectors btw - did not run it from command line but via a german app in Hiren's

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Well it was as simple as booting from an Arch linux live USB. I issued

$ mkdir /mnt/sda1
$ mount /dev/sda1 /mnt/sda1 # IIRC

arch said something in the lines of "the filesystem was not unmounted correctly - repairing". Then I booted from windows which run chkdsk and that was all. So hiren's app was a no-op and 3 cheers for arch

Problem solved

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.