Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a dell XPS 16 that shipped with Windows 7. When I upgraded to windows 8, various peripherals ceased to function, e.g. Bluetooth, SD card reader. I made sure to have the latest drivers (Most were for Win7, but it seems that they can be shared). I reinstalled my Ricoh SD card drivers manually to still no avail.

I looked into Ubuntu Linux, and surprisingly the OS worked "out of the box" with my bluetooth devices and my SD card reader. The thing is, I'm trying to write an ISO file to an SD card, and Linux doesn't seem to have the best programs, and the terminal hasn't worked (booting an rPI with wheezy and owncloud).

I'm wondering why this is. I assumed it was drivers at first, but how could a new operating system that was not factory installed detect my devices when Windows cannot? I understand the issues can vary and my problem is very broad, so general responses to look into are fine. I'm just not sure what route to take after ensuring all of my drivers are up to date.

share|improve this question
    
Does Device manager show all devices as installed and working correctly? –  Bala Sivakumar Oct 4 '13 at 4:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.