Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two computers running Windows 7 Professional. I have already forwarded the port successfully and I am using dyndns as my RD gateway(My home IP is dynamic).

When I connect remotely from the home network everything works well, I can disconnect and reconnect as many times as I want. However, when I connect from outside my LAN i.e. from school or using my phone data connection, I can connect only once, if I disconnect and then attempt to connect a second time, it won't work, it tells me that the computer is unreachable.

The computer at home continues to show "logged on" even though I already disconnected from it. If I login to the computer, then it will allow another remote connection but after that, it'll go back to showing "logged on" and won't allow me to connect anymore. Very annoying. Help would be highly appreciated.

Thanks!

share|improve this question

1 Answer 1

I thought there was a setting somewhere for "Remote Desktop", that when disconnected (and the session was still active) you only could reconnect from the same machine. (this was a very long time ago and perhaps it wasn't RD but PcAnywhere, I can't find it anymore)

What you could try is setting a time limit for disconnected sessions. That way, when someone disconnects, the session will be terminated after the timeout you set (1 minute for example) and you can hopefully logon again from the same location. Downside is that you loose your session so you need to end your applications or RDP will do it for you after the timeout.

On the host-machine do the following:

  • Click on Start button and type gpedit.msc, then hit Enter
  • Navigate to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Session Host > Session Timeout Limits.
  • Double-click Set time limit for disconnected sessions
  • Set it to Enabled and set End a disconnected session to a desired timeout.
  • Click Ok and close the "Local Group Policy Editor"
  • Restart the host-machine

Please note the changes you make in a computer-logbook for future reference for yourself or a computer-administrator.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.