Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Why do I get the fsck error: "currently, only 1 or 2 FATs are supported, not 34?" And what can I do to successfully run fsck?

I'm fsck-ing my Transcend 16GB Class-6 SD card. It got corrupted recently (not sure how). I already recovered the data. Now I'm trying to fix the card for re-use. I want to see if I can fix it without reformatting--using fsck.

Here's the output for running fdisk and fsck on Ubuntu 9.04:

billpaetzke@billpaetzke-desktop:~$ sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1aac1aac

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        9352    75119908+  83  Linux
/dev/sda2            9353        9729     3028252+   5  Extended
/dev/sda5            9353        9729     3028221   82  Linux swap / Solaris

Disk /dev/sdb: 16.0 GB, 16071000064 bytes
218 heads, 56 sectors/track, 2571 cylinders
Units = cylinders of 12208 * 512 = 6250496 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1        2572    15690240    b  W95 FAT32
billpaetzke@billpaetzke-desktop:~$ sudo fsck /dev/sdb1
fsck 1.41.3 (12-Oct-2008)
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
Currently, only 1 or 2 FATs are supported, not 34.
share|improve this question
up vote 3 down vote accepted

When you do a dosfsck you need to tell it what partition number - fsck's launching of dosfsck isn't quite cutting it in this case (maybe). Try running dosfsck directly:

sudo dosfsck -r -v /dev/sdb1

the -r option is for interactively fixing the file system

the -v option is for verbosity

If you still see the error, I suspect the filesystem is corrupted. The File system is indicating you have 34 file allocation tables, which is not possible - you'll need to reformat.

share|improve this answer
    
Thanks, Dave. I received the same error, after running your statement. I agree: the file system is corrupted. This problem is beyond fsck. I will reformat with GParted, unless you suggest something else. – Bill Paetzke Nov 4 '09 at 5:14
    
Actually, I've never tried reformating an SD card, I sort of think of them as disposable, since they have finite lifespans. – DaveParillo Nov 4 '09 at 5:23
1  
I reformatted it with GParted. It works again. I only had the card for seven months. So, I'm going to use it for awhile still. Next time, I'll buy SanDisk! :) – Bill Paetzke Nov 4 '09 at 5:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .