Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on Windows 8 x64 Enterprise Edition and I have the NFS Client/Server tools installed. It was working perfectly fine for me a few months ago.

Today I wanted to mount some NFS shares, so I opened up a command prompt, typed "mount" and got an error: "'mount' is not recognized as an internal or external command, operable program or batch file."

Surprised, I manually changed DIR to %windir%\system32 and ran a DIR, and ran "mount" but nothing came up.

But when I launched explorer and browsed to the folder, the files were present, and I was even able to launch them by double-clicking it.

enter image description here

If you check the above screenshot, you can see that both a normal and elevated cmd can't see the files, but explorer can.

File attribs are normal (only 'A'), and all users have read/execute permissions. I haven't touched UAC. I'm not running any special security software nor any antivirus. It doesn't seem to be affecting any other executables present in system32. My PATH variable looks fine as well.

I have tried uninstalling and re-installing the NFS tools, ran CHKDSK several times and rebooted, but nothing seems to have fixed it. Note that this is affecting all NFS tools - (nfsadmin, nsfshare, umount etc)

Is there any fix for this, short of a format+reinstall? More than the fix, I'm curious as to the actual reason this has occurred. In all my years of computing, I have never come across something like this. And no, cmd.exe isn't running in a sandbox or a virutal machine. The only thing close to a VM though is my C: is a VHDX and I'm booting off it, but that's never caused any issues before.

Would appreciate any thoughts on this issue.

share|improve this question
    
Are you using the 32bit version of Xplorer Square? In that case 'C:\windows\system32' really shows the content of 'C:\Windows\SysWOW64', use the 32bit version of cmd.exe –  Peter Hahndorf Oct 3 '13 at 8:51
    
@PeterHahndorf : Good guess, but no, it's the 64bit version. Using the real explorer has the same result as well - it says the files are located in system32. Corollarily, cmd.exe also says mount.exe isn't present in SysWOW64. –  d3Xt3r Oct 5 '13 at 21:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.