Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

From FileZilla, I can successfully connect to my webserver but attempting to upload any file to any location fails. Here is the log of that process:

Status: Resolving address of mythofechelon.co.uk
Status: Connecting to 212.48.67.44:21...
Status: Connection established, waiting for welcome message...
Response:   220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:   220-You are user number 1 of 50 allowed.
Response:   220-Local time is now 13:14. Server port: 21.
Response:   220-IPv6 connections are also welcome on this server.
Response:   220 You will be disconnected after 15 minutes of inactivity.
Command:    USER ben
Response:   331 User ben OK. Password required
Command:    PASS **********
Response:   230 OK. Current restricted directory is /
Command:    SYST
Response:   215 UNIX Type: L8
Command:    FEAT
Response:   211-Extensions supported:
Response:    EPRT
Response:    IDLE
Response:    MDTM
Response:    SIZE
Response:    MFMT
Response:    REST STREAM
Response:    MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Response:    MLSD
Response:    AUTH TLS
Response:    PBSZ
Response:    PROT
Response:    ESTA
Response:    PASV
Response:    EPSV
Response:    SPSV
Response:    ESTP
Response:   211 End.
Status: Server does not support non-ASCII characters.
Status: Connected
Status: Retrieving directory listing...
Command:    PWD
Response:   257 "/" is your current location
Command:    TYPE I
Response:   200 TYPE is now 8-bit binary
Command:    PASV
Response:   227 Entering Passive Mode (212,48,67,44,171,207)
Command:    MLSD
Response:   150 Accepted data connection
Response:   226-Options: -a -l 
Response:   226 32 matches total
Status: Directory listing successful
Status: Retrieving directory listing...
Command:    CWD public_html
Response:   250 OK. Current directory is /public_html
Command:    PWD
Response:   257 "/public_html" is your current location
Command:    PASV
Response:   227 Entering Passive Mode (212,48,67,44,54,40)
Command:    MLSD
Response:   150 Accepted data connection
Response:   226-Options: -a -l 
Response:   226 9 matches total
Status: Directory listing successful
Status: Resolving address of mythofechelon.co.uk
Status: Connecting to 212.48.67.44:21...
Status: Connection established, waiting for welcome message...
Response:   220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:   220-You are user number 2 of 50 allowed.
Response:   220-Local time is now 13:14. Server port: 21.
Response:   220-IPv6 connections are also welcome on this server.
Response:   220 You will be disconnected after 15 minutes of inactivity.
Command:    USER ben
Response:   331 User ben OK. Password required
Command:    PASS **********
Response:   530 Login authentication failed
Error:  Critical error
Error:  Could not connect to server
Status: Delaying connection for 5 seconds due to previously failed connection attempt...

Original diagnostic results:

  1. The same issue occurs using a fresh install of FileZilla 3.7.3 (the latest version)
  2. The same issue occurs on multiple PCs
  3. The same issue has occurred on multiple sites and, therefore, different internal networks
  4. I can successfully upload via cPanel's File Manager

Edit:

New diagnostic results:

  1. Changing FileZilla's transfer type to Auto, ASCII, or Binary doesn't make a difference
  2. After the file transfer fails, disconnecting from the server and attempting to reconnect also fails. Quitting and re-launching FileZilla allows me to reconnect again
  3. The same issue occurs on a freshly-installed Windows 7 x64 VM with a bridged network, no security software, and default Windows firewall rules
  4. Using WinSCP (as suggested by Ryan) with the same credentials works
share|improve this question
1  
It looks like your Login authentication failed. Make sure your password is correct. –  Ryan Oct 3 '13 at 12:39
    
Have you tried to change the upload mode. The server status message is pretty clear. –  Ramhound Oct 3 '13 at 12:40
    
@Ryan I believe it uses the same password as the one used to initially connect, which worked without issue. –  mythofechelon Oct 3 '13 at 13:03
    
Maybe it has problems with antivirus and/or firewall? –  Jet Oct 3 '13 at 13:14
    
You could try using another FTP client and seeing if it is a Filezilla issue or an authorization issue to be sure. I believe WinSCP is still free. –  Ryan Oct 3 '13 at 15:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.