Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm connected through a public wifi hotspot. No problem when using IExplorer. When I use Firefox, I obtain the following error message after asking for any https url, as for example https://www.google.com:

An error occurred during a connection to www.google.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

How can I solve?

share|improve this question
2  
check your proxy... – PersianGulf Oct 3 '13 at 16:36
2  
This can occur because of a misconfiguration of AntiMalware software that includes "internet security" or because something in the chain is redirecting the https URL to http, and your browser does not like it. – Richie Frame Oct 5 '13 at 8:17
    
So, there is a proxy or AntiMalware that prevents Firefox from working but not IExplorer? Really? – Toc Oct 5 '13 at 9:44
    
The problem may not be due to a proxy or antimalware issue, but Firefox can be configured to use the system proxy settings, which is what Internet Explorer uses, or can be configured to use a manual proxy setting in which case even though Internet Explorer may not be routing your HTTP/HTTPS connectivity through a proxy, Firefox may be using a proxy. Also, with some antimalware products, you can configure the software for "safe surfing", which might be turned on for one browser, but not another. – moonpoint Jul 25 '15 at 2:15

This problem can be repair with uncheck the TLS encryption. Tools > Option > Encryption (tab) > and uncheck TLS 1.0.


Update.

Look for these preferences(security.tls.version*).

  • security.tls.version.min
  • security.tls.version.max

In the Awesomebar, type or paste about:config and tap the Go arrow. Type tls into the search box and tap the Enter key to find all preferences that contain tls.

According to a comment in the code:

// 0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, etc.

So try setting both min and max to 2, to force TLS 1.1, and see whether that works.

See Reference

share|improve this answer
    
Sorry, tried with no luck. Same error as before. – Toc Oct 3 '13 at 16:39
    
@Toc updated my answer with a possible solution. – quark8 Oct 3 '13 at 17:11
    
Sorry, nothing even after your update. By the way, Firefox 24 does not have Encryption tab on Adavnced section in options window. – Toc Oct 4 '13 at 13:06
    
Furthermore, by the way, I have recognized that my IE is set to use TLS 1.0 and not 1.1. – Toc Oct 4 '13 at 13:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .