Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed the Holux M-241 Bluetooth device on Ubuntu host.

I am the stage, when I can read the raw data from the device on host using sudo cat /dev/rfcomm4.

Now, I connected the device to VirtualBox guest by "Serial Ports". image 1. (Prior to that I had to change permissions on this port: sudo chmod user:user /dev/rfcomm4.) This connection began to be available on Windows guest, as COM3.

Unfortunately, no GPS data there. Neighter GPS software, nor simple portmon.exe can show any activity on the COM3 port.

Instead of Port Mode "Raw File", I tried also Host Pipe mode, and that gave an error:

Failed to open a session for the virtual machine DabSad.

NamedPipe#0 failed to connect to local socket /dev/rfcomm4 (VERR_NET_CONNECTION_REFUSED).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

This error is the same even if the bluetooth is actually off, and the device is not paired anymore.

I also tried mode Host Device. That looks promising, but I got bizarre behaviour on guest: it was keeping pressing the key (or the right mouse key). I couldn't test anything.

What did I do wrong? Is forwarding like this is possible at all (Googling showed me, that it is possible to forward guest->host, and guest1->guest2).

I use Linux Mint 15, based on 3.8.0-31-generic kernel, and VirtualBox 4.2.10

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.