Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to connect my old Vista PC to the internet by routing it thought my windows 7 laptop which has Wi-Fi. I am using an Ethernet cable to do this but every time I try to get it share the internet I get the error.

    A error occurred while Internet Connection Sharing was being enabled.
    This specified service does not exist as an installed service.

What should I do?

share|improve this question
    
What version of Windows 7? ICS requires at least Home Premium . . . –  ernie Oct 3 '13 at 17:42
    
Ernie has a very good point. Especially given your error: "This specified service does not exist as an installed service." –  Hennes Oct 3 '13 at 17:45
    
how do I check what windows I have –  dashernasher Oct 3 '13 at 17:48
    
Either 1) go to the [start] menu and then to "My computer". Right click on it and select properties. or 2) Go to the icon on the desktop. Right click on it and select properties. 3) Or go to control panel system (Control Panel\All Control Panel Items\System). It will display something like this –  Hennes Oct 3 '13 at 17:51
    
I am running home premium –  dashernasher Oct 3 '13 at 17:57
show 2 more comments

1 Answer

You need a Crossover cable.

http://en.wikipedia.org/wiki/Ethernet_crossover_cable

This will allow the two computer to communicate as if there were a switch or router between them, and allow you to bridge to the wireless connection.

Also make sure all the required services are set to automatic and are running.

Possible Solution: Click Start, Run, type services.msc, and click OK. To enable a service, find it in the right pane and double-click its entry. Be sure its Startup Type is set to Automatic and click OK. All the following services must be configured in order to use ICS:

  • Application Layer Gateway Service
  • Network Connections
  • Network Location Awareness (NLA)
  • Plug And Play
  • Remote Access Auto Connection Manager
  • Remote Access Connection Manager
  • Remote Procedure Call (RPC)
  • Telephony

After verifying and/or configuring Automatic startup for each of these services, close the Services window and restart the computer before attempting again to enable ICS.

share|improve this answer
1  
Clarification: You need a crossover cable if there is no support for MDI/MDX. Any modern device will have that and a crossover cable is not needed nor will it result in the error you got. (If you got gbit NICs then it is even required to have MDI/MDX). –  Hennes Oct 3 '13 at 17:45
    
I have this: link is this ac crossover cable –  dashernasher Oct 3 '13 at 17:46
    
That is not a cross over cable, that is a standard Cat-6 Ethernet cable... –  TheX Oct 3 '13 at 17:47
    
Note there is no physical difference in the cable unless you look at how it is terminated, the wires will be wired differently... –  TheX Oct 3 '13 at 17:48
1  
Yes that would work, but as @Hennes said I am not sure that is going to fix that specific error that you are seeing... –  TheX Oct 3 '13 at 17:55
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.