Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My i5 750 seems to be stuck on the idle multiplier (9x) instead of the base speed of 2.66 GHz, even while loading using Prime 95

Configuration:

  • i5 750
  • DP55WB desktop motherboard.
  • 2GB DDR3 RAM
  • PSU: Corsair Vx450W
  • GPU: MSI ATI 5770 HAWK

enter image description here

Any idea whats going on?

In addition to the troubleshooting in the comments, I tried going to power options and setting the minimum processor state to 100%. No effect at all

share|improve this question
1  
Need information on the BIOS settings. Are you unable to change the multiplier in BIOS? I would try restoring the default settings. –  Ramhound Oct 3 '13 at 18:34
    
@Ramhound I tried Reset defaults but did not try setting an explicit multiplier given the huge warning about breaking something before I could get to the config screen. Is it relatively safe to use the settings to force a multiplier supported on stock since the processor does not seem to be using it automatically ? –  Akash Oct 3 '13 at 18:48
    
I just fired up CPU-Z on my own desktop and I can at least confirm that the multiplier it shows should change when the CPU is non-idle. I just watched my go from the normal x12 (idle) to x21 (during prime95 stressing). –  Hennes Oct 3 '13 at 18:51
    
@Hennes yup, thats how its supposed to happen and used to happen (and similarly, the temps dont increase either, usually they used to flat out at 80C on P95, now they flat out at 55-60C) –  Akash Oct 3 '13 at 18:53
1  
@Akash - Alright. Your inability to POST in the past is important information. This points to a possible BIOS configuration corruption. I would attempt to apply the current BIOS update and see if it will allow you to reapply it. –  Ramhound Oct 3 '13 at 19:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.