Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm new to Linux and I would like to setup a simple download server on my RaspberryPi.

I installed FatRat via:

apt-get update
apt-get install fatrat

Since I'm not using a GUI on RaspberryPi, I need to start the HTTP server to connect to RPi via web browser. According to FatRat manual I need to do this (source: http://fatrat.dolezel.info/faq):

A: You can use fatrat-conf to set configuration values from the console. The rest can be done through the web interface (this is work in progress in Git!). This is how you can enable the web interface, set the port and change the default password:

fatrat-conf -w remote/enable=true remote/port=PORT remote/password=PASSWORD

But when I try to run the command

fatrat-conf -w remote/enable=true remote/port=2222 remote/password=mypass

I get "command not found"

When running without GUI (-n = no GUI)

sudo fatrat -n

I just get:

FatRat is up and running now

but the process is active in foreground so I can no longer use console unless I quit it by ctrl+c

How can I start the web interface?

share|improve this question

2 Answers 2

Try:

sudo fatrat -n &

The "&" character sends the process to the background.

share|improve this answer
    
Ok, the process is running (i can see it at: ps aux | grep fatrat), but how can I start the web server to be able to use it? –  Joudicek Jouda Oct 7 '13 at 23:41
up vote 0 down vote accepted

To be able to start Fatrat from SSH console it is needed to start it using nohup (ignoring hangup signal):

sudo nohup fatrat --nogui &

I wasn't able to change Fatrat settings using console, so I used TightVNCServer to remote desktop login and then changed everything via GUI.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.