Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Promise NS4300 server which contains 285Gb of user files. The windows protocol died so we could no longer access the hard drive (1 drive, no RAID). The support suggestions from Promise didn't help. Last one was to use a Windows recovery utliity (no suggestions: don't they have one!) to recover the files.

I tried putting the drive in a windows PC but Disk Manager couldn't recognise it. It might be a proprietry partition format.

I have accessed the NAS through Apple Talk on an old OS 9 MAC and can see all the folders and files but need a faster method of recovering the files not involving a USB external drive or the ethernet connection (covered in another post in more detail).

Does anyone know of a utlity or driver that will do the trick and make the NAS disk partition accessible or visible in Windows?

Edited by author: Maybe this will help. I think the NAS box runs on a version of Linux. It was not set up as a RAID since only 1 drive and shown in the NAS network properties as RAID0 I think.

Edit 4/10: I checked the NAS Raid info: It is RAID0 (1). This must be a special case as a RAID recovery utility I ran wouldn't accept a single drive for RAID0. I inserted the NAS drive in a USB enclosure and booted from my Knoppix Live CD. It comes with a raid recovery util. I ran it and it detected it as a Linux file system, SUPERBLOCK Ext2 I think. However it insisted there should be 2 drives for RAID0 so couldn't access or recover the files. As was pointed out, a hardware RAID controller mayb be needed to unscramble the drive so I will try the same thing today in my home PC which has RAID support built-in to the disk controller. If anyone knows of a good RAID file recovery utility please let me know.

Edit 6/10 (further experimentation): Took the NAS HD home and connected to PC by USB. Drive not readable in Windows or Knoppix (LInux). Then mounted drive in PC (SATA). Again not readable in Knoppix File Manager. Knoppix comes with some RAID utilities so tried them. See it as a RAID but will not accept RAID0 with 1 HD only. Booted to XP and downloaded 4 or 5 RAID recovery utils including one suggested here. All of them had the same problem. They recognised the RAID and the Linux Ext2 file system but showed it as RAID1 (which it's not). WHen I tried to set to RAID0 they wouldn't proceed, insisting on a second drive. The problem may be that the NAS drive needs a hardware RAID controller (@Aaron Miller), or that Promise create it as a non standard RAID. When in the NSA box it doesn't display as a single drive as such - it shows as RAID0 but isn't really because RAID0 required 2 drives to stripe. Anyway, I think I've run out of things to try, unless someone has more suggestions? You would really think Promise would have a recovery utility for their NAS boxes. It's so frustrating to know the files are sitting there on the HD in my PC but I can't get at them! Thanks all suggstions! PS: I it worth downloading UBUNTU, would it be any different to Knoppix? Does it come with RAID utils?

share|improve this question
    
Try booting from an Ubuntu Live CD and copy from there? –  David Oct 3 '13 at 20:22
    
Wait, so it's RAID 0 across one disk? If so, you may be hosed with respect to reading the disk on another machine; RAID 0 stripe volumes are famously impossible to read with any disk controller that doesn't have the stripe information in its NVRAM. (The filesystem might be e.g. ext4, but the RAID controller plays its own games with the bytes before putting them on the platters, so what's actually on the disk doesn't look anything like ext4.) –  Aaron Miller Oct 3 '13 at 20:28
    
@David That doesn't sound good! I'll checkup on what the NAS disk config says tomorrow. I think it was RAID0 and thhere didn't seem to be another category for a single drive except that. I'll try my bootable Linux-on-a-CD tomorrow to see if it can see read the drive. By the way my home PC has a RAID controller built-in. If I boot from a Linux CD would that work? I'll try and download a proper UBUNTU CD tomorrow. –  Mike Berryman Oct 3 '13 at 21:09
    
Yes, this is quite an easy process. Find wherever the files on the Promise NS4300 server disk were backed up to and then restore from the backup. If anyone knows of a good RAID file recovery utility please let me know. R-Studio Network Edition. –  ta.speot.is Oct 5 '13 at 6:57
    
@ta.speot.is: Unfortunately no backups exist. In addition the backup/restore facility is also not working. The system was made available to the users with the understanding they could share their workgroup files using it but were responsible for their own backups. Naturally none did make backups and are pressuring me to recover their files now. Othereise I would have re-formatted the drive already. –  Mike Berryman Oct 5 '13 at 7:03
add comment

2 Answers

I think you are going about it wrong. Instead of trying RAID recovery utilities (assuming you haven't already destroyed the data by doing so) get a partition manager; that will automatically tell you what filesystem is on the disk and, if it's readable, will let you "explore" the disk to see the files, even though it won't be able to recover them.

Something is very wrong with the NAS if getting files off it is slow even by USB connection. Possibly the disk is failing, though you say you can still see the files on it.

Promis does not use their own disk format; they make controllers. So the file system on the disk is going to be readable, -unless- it is a striped RAID that is missing half the set. Since it is one disk, this would be very doubtful as that would completely defeat the whole purpose of RAID.

It would be helpful to know the exact model of the Promis box, and whether there were really two disks but you just removed one (as your comments would suggest.) RAID0 (1) would suggest that what you have is disk 1 of the two drives required for RAID0; the best way to recover the data is to put the disk back into the enclosure and pair it back up with the other disk so that the RAID volume is intact, then plug it in via USB. You cannot do this with only have the disks of the set, however.

share|improve this answer
    
thanks for your post. If interested please see this previous post at superuser.com/questions/653389/… and you'll understand the background to the problem and which led to this question. Briefly something got corrupted and the NAS4300 WIndows and FTP services would no longer start. But I was able to access the box through an old Apple and Appletalk. Getting the files off was extremly slow because of the slow Apple hardware. I then decided to try extracting the data direct from the drive. –  Mike Berryman Oct 7 '13 at 15:30
    
PS: it is single drive. But the NAS RAId utility displays it as RAID(0) so I thought it was some unusual kind of RAID. The NAS will not start the Windows or FTP service - only AppleTalk and Linux which we don't use. Please see latest positive results in question edit. –  Mike Berryman Oct 7 '13 at 15:34
add comment
up vote 0 down vote accepted

I believe I have answered my own question. I tried various Ext file system viewers (e.g. Ext2 File system, Ext2Read, Ext2fsd, Paragon ExtFS, etc) but none worked. Finaly I tried the upgraded version of Explore2fs, Virtual Volumes. which worked! Yaay! I was now able to directly export the NAS folders to windows quite easily though the process was fairly slow. I had to do 1 root folder at a time else it seemed to hang. The program seems to work quite well, though the user interface stops dead when copying files so I would guess it uses a single thread for both. Would be nice if that could be upgraded, though it is still in beta (0.7). So my 2 week mission to get the files off is over. Thanks to the author of Virtual Volumes (http://www.chrysocome.net/virtualvolumes). Oh forgot to mention Vitual Volume worked on my home XP PC with the drive internally connected by SATA. I tried the same thing on my work Win7 PC but VV wouldn't detect anything until I removed the drive and connected it via a USB enclosure. Not sure why internal SATA didn't work. Finally I tried booting from a Ubuntu CD but the NAS drive wasn't detected. That was with drive internal. I never tried Ubuntu with the drive in USB. Thanks all who offered suggestions!

share|improve this answer
    
I disovered today the Virtual Volumes wouldn't show the Ext2 drive on Win7 unless it was run as Administrator. The semi-frozen user interface is a nuiscance, and the whole copy process is too slow. Also it appears that with big root folder (50-100Gb) it appears necessary to copy their sub-folders a couple at a time. If the amount to be copied is very large the initial loading of the files and folders never seems to complete. Despite these drawbacks it's still the only reader I tried that could see the NAS drive. –  Mike Berryman Oct 8 '13 at 15:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.