Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Occasionally, one of my users will be unable to connect to our web-based email (simple timeout, page cannot be displayed, errors). The problem persists for days (and between reboots) then eventually resolves itself, only to reoccur some time later. I checked all the basics, then broke down and took a packet capture.

It looks like the mail server simply does not respond.

Packets go out, and after a while, a reset would come in. The user was initially behind double NAT. After removing the second router, the resets disappeared, leading me to believe something in the middle was sending resets. Now I see Bad CheckSum errors on the requests sent from the browser. I disabled TCP checksum offloading, which changed nothing. Most other packets do not show a Bad CheckSum error. All of the packets headed towards our server do show the error.

The site works on other computers on the network. If I switch to a mobile hotspot, the site works. If I load the site in web-based proxy, it works (probably irrelevant). Switching to WiFi on the same connection (to eliminate driver issues) does not work. I checked the firewall and logs server-side; everything seems normal.

What can I do to troubleshoot this issue?

Sorry for the bad title. If you think of something clearer, feel free to edit.

share|improve this question
1  
I know you mentioned switching to Wi-Fi, but have you tried assigning a new IP address? This is very odd. –  user3463 Oct 4 '13 at 21:48
    
I assigned a new IP address when I moved the machine away from the nasty double-NAT setup. I did, however, keep the same router in play. Rebooting the router didn't help, and I don't think it has to do with the router. –  Tanner Oct 4 '13 at 22:18
    
Try a different router then. How old is it? I'd suggest checking the switch as well, but you already tried with Wi-Fi. –  user3463 Oct 4 '13 at 22:33
2  
it almost sounds like a routing or MTU issue. But have you tried booting a Linux live-cd to eliminate the local OS during the 'outage'? –  R Hughes Oct 5 '13 at 20:17

1 Answer 1

Edit the HOSTS file on that machine to specify the IP address and fully qualified domain name of your mail server.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.