Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Sysinternals Process Explorer installed as the system's task manager (Win7 64). Since half of the metrics for anything started as service and processes started under other user accounts are either silently missing or shown wrong, I would like to run Process Explorer as administrator by default.
Selecting the appropriate item from the menu after failing to perform an action on a process or wondering why some metric is not at all plausible (e.g. no I/O happening when the disk is very obviously reading/writing gigabytes of data, such as during a system backup operation) certainly does "work", but is a recurring, major inconvenience.

The Run as Administrator checkbox in file properties works for tools that you launch by clicking on an icon or a launcher (such as e.g. Autoruns) although it triggers UAC in a sheer stupefying manner every time.
I understand this is a "Feature" of the super smart Windows security system that cannot be avoided other than by turning off UAC completely, which frankly is the second most stupid design decision I've seen in my life.

The bigger problem I'm facing, however, is that enabling said checkbox for Process Explorer will disable the task manager. Ctrl-shift-ESC shows a busy cursor for a fraction of a second and doesn't seem to do anything else. Selecting "Task Manager" from the context menu on the task bar shows an alert stating that higher privilegues are needed to complete this operation (duh, that's exactly what the user is asking for!). The secure attention sequence brings up the lock screen. Clicking on "Task Manager" there does nothing.
Unchecking the checkbox makes Process Explorer work seamlessly again, but it (unsurprisingly) runs as normal user.

Apparently, the Windows guys are concerned that some malware that has already completely subverted the system to a point where it can bypass the secure attention sequence might be able to launch a program as administrator. Good grief.

Is there a workaround to both have Process Explorer come up when hitting Ctrl-shift-ESC (or the attention sequence) and running as administrator?

share|improve this question

1 Answer 1

First, create a ->Startup shortcut that points to Process Explorer so that it runs when you start windows.

Go to the properties for this shortcut and add the /t option. This tells Process Explorer to run as an administrator. I also use /e option which automatically bypasses the EULA nag that the tools author hates but was forced by the lawyers to add. So, my shortcut looks like this:

   "C:\Program Files\SysInternals\procexp.exe" /e /t

Finally, within Process Explorer, check "Hide When Minimized" from the Options menu. Now, when you close the window, Process Explorer will disappear to the system tray. Ctrl+Shift+Esc (or any other shortcut to Task Manager) will reopen your existing (Administrator) Process Explorer instance.

(To actually end the process, right click the system tray icon or use process explorer to kill itself. Tedious, but I rarely find the need for this.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.