Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to set up dual monitors for my Ubuntu (9.04) laptop. I have the nvidia driver installed so it uses the nvidia configuration application. I make the change that I need to set and it says that it needs to be restarted before it will take effect, but when I try to write the changes to file, it says it can't create a backup file so my changes never take affect.

How can I get this to work?

share|improve this question
    
Are you running the configuration utility as root? (ie, via sudo or gksudo?) –  Matthew Scharley Nov 4 '09 at 8:04
add comment

1 Answer 1

up vote 1 down vote accepted

This is, because the Folder /etx/X11 and all its contents are owned by root. When changing steeings, a backup of xorg.conf should be created and your current user has no rights to do it. Try executing this as a super user, like this:

sudo nvidia-settings

EDIT:
On Gnome you should use

gksudo nvidia-settings

On KDE you should use

kdesudo nvidia-settings
share|improve this answer
    
I knew that was the problem, I just didn't know how to switch to the super user to run the application. Why didn't the application just ask me for my password? Is there another way to switch to the super user before opening an application? –  Andrew Nov 4 '09 at 23:25
    
If you want to always run a program as super user, then you can change the shortcut command to that program to include the gksudo command. However, this does then make it a hassle to run without elevated privileges and generally isn't worth it. –  Dom Apr 6 '10 at 21:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.