Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a raspberry pi with MySql installed which has been working fine for 4 months.

I played with 3 settings on MySql and now it will not start.

I changed innodb_log_file_size to 100MB, innodb_buffer_pool_size to 300MB and innodb_write_io_threads to 8.

Then on a reboot mysql did not restart. If I run /etc/init.d/mysql restart I get the error "the partition with /var/lib/mysql is too full"

The SD card has 19GB of space free.

So I modified the /etc/mysql/my.cnf file to set the settings back then rebooted but still no luck.

What on earth has happened?

Edit----

I am using Raspbian OS

Ok so I think my partitions are as follows

Filesystem       Size      Avail

rootfs           30G       19G
/dev/root        30G       19G
devtmpfs         235M      235M
tmpfs            49M       49M
tmpfs            5M        5M
tmpfs            98M       98M
/dev/mcblk0p1    56M       38M

I have now tried a new SD Card with a fresh install of raspbian and MySql. I am for some reason getting the same error despite the card only being 29% full. This is on a brand new install trying to start MySql for the first time! What on earth is going on?

share|improve this question
    
Have you tried getting rid of some files. I assume there are multiple partitions, what is the usage, on the partition? –  Ramhound Oct 4 '13 at 15:11
    
I have no idea if there are multiple partitions. How do I tell? –  coolblue2000 Oct 4 '13 at 15:14
    
Research what command would list the number of volumes you have on the operating system your using. You don't indicate what your using. –  Ramhound Oct 4 '13 at 15:18
    
Ok I have edited my post –  coolblue2000 Oct 4 '13 at 15:27
    
None of my partitions have 100% usage the most is 35% and they still have 19G free –  coolblue2000 Oct 4 '13 at 15:29

1 Answer 1

Then on a reboot mysql did not restart. If I run /etc/init.d/mysql restart I get the error "the partition with /var/lib/mysql is too full"

Free up some space on /var or break open your my.cnf (if that's the name of the configuration file) and put your database on a partition with more room.

The SD card has 19GB of space free.

This doesn't mean the partition /var lives on has 19GB free. Your distro, when you installed it, may have only given this partition 1 or 2GB of space. You may need to move the database elsewhere in your filesystem.

Use a mount command to find out what partitions you have, and df -h to check the free space on them.

share|improve this answer
    
I have edited my post to list the partition sizes. How do I know what partition MySql is installed on? –  coolblue2000 Oct 4 '13 at 15:28
    
Hmm ... can't tell from that, sorry. Do a cat /etc/fstab –  ultrasawblade Oct 4 '13 at 15:29
    
This tells me "proc /proc proc defaults 0 0,/dev/mmcblk0p1 /boot vfat defaults 0 2,/dev/mmmcblk0p2 / ext4 defaults,noatime 0 1" –  coolblue2000 Oct 4 '13 at 15:33
    
I have discovered that if I delete one of the large dbs then the rootfs and /dev/root partitions both get more available space which suggests these are the install partitions (I assume both are the same thing) Which means there is a load of space available on them. –  coolblue2000 Oct 4 '13 at 15:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.