Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded my Linux Mint from 14 to 15 the apt way, and since then my vagrant box is not able to start up fully. Either the network interface or the /vagrant folder is not getting setup..

ERROR warden: Error occurred: Agent pid 1034

/usr/lib/ruby/vendor_ruby/net/scp.rb:385:in `await_response_state': Agent pid 1034 (RuntimeError)
        from /usr/lib/ruby/vendor_ruby/net/scp.rb:356:in `block (3 levels) in start_command'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/channel.rb:311:in `call'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/channel.rb:311:in `process'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/session.rb:214:in `block in preprocess'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/session.rb:214:in `each'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/session.rb:214:in `preprocess'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/session.rb:197:in `process'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/session.rb:161:in `block in loop'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/session.rb:161:in `loop'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/session.rb:161:in `loop'
        from /usr/lib/ruby/vendor_ruby/net/ssh/connection/channel.rb:269:in `wait'
        from /usr/lib/ruby/vendor_ruby/net/scp.rb:279:in `upload!'
        from /usr/lib/ruby/vendor_ruby/vagrant/communication/ssh.rb:81:in `block in upload'
        from /usr/lib/ruby/vendor_ruby/vagrant/communication/ssh.rb:110:in `connect'
        from /usr/lib/ruby/vendor_ruby/vagrant/communication/ssh.rb:79:in `upload'
        from /usr/lib/ruby/vendor_ruby/vagrant/guest/debian.rb:38:in `configure_networks'
        from /usr/lib/ruby/vendor_ruby/vagrant/action/vm/network.rb:72:in `call'
        from /usr/lib/ruby/vendor_ruby/vagrant/action/warden.rb:33:in `call'
        from /usr/lib/ruby/vendor_ruby/vagrant/action/vm/clear_network_interfaces.rb:26:in `call'
        from /usr/lib/ruby/vendor_ruby/vagrant/action/warden.rb:33:in `call'
        from /usr/lib/ruby/vendor_ruby/vagrant/action/vm/host_name.rb:10:in `call'
        from /usr/lib/ruby/vendor_ruby/vagrant/action/warden.rb:33:in `call'
        from /usr/lib/ruby/vendor_ruby/vagrant/action/vm/share_folders.rb:20:in `call'

This is the error I am seeing while setting up the network, if I disable the network, I get a similar error at the /vagrant folder setup stage.

I have tried to purge vagrant and reinstall, and I even did that with autoremove inbetween. Nothing helped. What I havent tried is to purge Virtualbox too.. would that help?

Edit: got this while trying to start a new vagrant box would this be relevant?

[default] The guest additions on this VM do not match the install version of
VirtualBox! This may cause things such as forwarded ports, shared
folders, and more to not work properly. If any of those things fail on
this machine, please update the guest additions and repackage the
box.

Guest Additions Version: 4.2.0
VirtualBox Version: 4.2.10
share|improve this question
    
Definitely. You should really change the Guest additions, and then report back whether this fully solved your problem, or there is something still left behind. –  MariusMatutiae Oct 6 '13 at 10:35
    
@MariusMatutiae tried to install a plugin which was supposed to auto install the latest, but then that started giving trouble.. I caved and destroyed my box –  Karthik T Oct 6 '13 at 12:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.