Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've seen this happen on 2 different HP laptops now. If I try to use them in the same room as a Media Center, the MCE TV remote keeps sending commands to the laptop. This can do anything from wake it up and turn it on to just moving the selection around.

There is no obvious way to disable the IR sensor or at least its response to the remote. Does anyone know how to do this?

share|improve this question
add comment

8 Answers

up vote 2 down vote accepted

You can't disable it in drivers, HP tied in their remote IR sensors into the keyboard input. The IR driver is actually for something else, the IR hardware is tied in to the keyboard.

IR driver = For additional hardware you may someday add on.

Keyboard driver = IR remote control (the thing you want to shut down)

So the only way to disable it driver wise is to take your keyboard offline too

No...

The only way to shut it off is to remove the hardware with a small axe (hatchet), or to cover it up with something.

It is an amazing feature to be sure, a very smart hack, but you cannot shut it off.

share|improve this answer
add comment

If nothing else works, you could just locate the driver for the IR device and disable/uninstall it.
This discussion refers the Microsoft DevCon tool to do exactly that.
Some more discussion here.

share|improve this answer
add comment

Put a mug of coffee/tea in front of the sensor.

This method has the advantage of not needing any driver deactivating/reactivating, it's easy to set, and unset!

If you prefer playing with drivers, you can deactivate it in the device manager, it will most likely be the one described at this link.

device manager with infrared receiver device

share|improve this answer
    
+1 I like the obvious non-technical answer. Sometimes the simple stuff does the job! –  DHayes Nov 4 '09 at 14:08
    
It might be hard to keep a mug of coffee in front of a laptop though... :) –  Steve Rowe Nov 6 '09 at 4:43
    
Depending on the table, actually, but if the sensor is in the middle, it can work good :-] Though you could put something more useful and mostly potentially less dangerous, like something to rest hands while typing, would be good both for your wrists, and blocking sensor ;) –  Gnoupi Nov 6 '09 at 8:55
add comment

This exact problem drove me crazy with my HP dv2500 reacting to my xbox360 remote, I even contacted HP tech support and their response was to cover the port with tape or a sticker. It turns out that didn't even work somehow the IR signal got through the tape. I decided to try a more surgical approach and found the smallest drill bit I owned. I carefully drilled a small hole through the front plastic of the IR receiver and eased the bit forward till i felt it contact something. I drilled only about a mm further to ensure I destroyed the IR receiver and it worked beautifully. I will warn this is a permanent fix, but for those people who have never and will never use an IR remote for their computer and are frustrated by the lack of software controls this will take care of the problem.

share|improve this answer
    
Why couldn't they just put it in the BIOS and make it easy? –  Steve Rowe Mar 24 '10 at 5:29
add comment

I use Event Ghost. It works with some R/C keys, not all of them.

enter image description here

share|improve this answer
add comment

You can disable the infrared port by disabling all of the hardware that controls it. Open Device Manager and choose 'View - Devices by connection'. Expand 'Consumer IR devices' and select 'Microsoft e-home infrared transceiver'. Disable HID-compliant consumer control device, HID-compliant device (there may be more than one) and HID-compliant mouse. Reboot and enjoy not having your HTPC remote control your laptop :)

share|improve this answer
add comment

An easier way is to:

  1. Go to C:\windows\system32\drivers
  2. Rename hidir.sys to hidir.sys.bak (admin privileges required)
  3. Reboot
share|improve this answer
add comment

I just put some tin foil on the sensor (just beside the headphone plugins).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.