Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem in my network. I have one network with 3 computers, 1 printer and 1 windows server version 2008. All computers in the network connected to the server have 192.168.1.xxx- IP addresses.

  • Router (192.168.1.1)
  • Computer 1 (192.168.1.100)
  • Computer 2 (192.168.1.102)
  • Computer 3 (10.250.20.100)
  • Printer (192.168.1.103)

Ok my problem is that computer 3 has a different IP address and can't communicate with the printer. All computers and printers are connected to the same router and the same windows server 2008.


Edit: The computer called "computer 3" is a Windows machine running as guest in a virtual machine (Parallels). The host machine is an iMac, that has a valid NAT-IPv4 address. The Windows machine (inside Parallels) is the one that is not able to communicate with the printer.

share|improve this question
    
Please don't cross-post to multiple Stack Exchange sites. –  Michael Hampton Oct 5 '13 at 18:23
    
As far as I have understood your question, you want to add "Computer 3" to your LAN, so it is able to reach the printer and your home server, right? What operating system is running on your third computer? Is the DHCP service running on your router? Finally is your third computer connected to the router via cable or wireless? If wireless, check that your third PC is actually connected to your router. –  Creaturo Oct 5 '13 at 18:33
    
How are IP addresses assigned? The 2008 Server DHCP or a router perhaps? –  Dave M Oct 5 '13 at 18:36
    
hi @th3m3s thank you for your reply, yes that's my question. my 3rd computer is a iMac with Parallels (windows+mac) in mac system is all working, actually when i go in my windows server 2008 i can see "iMac" in the network but i also need the windows on it. Actually i don't know how to check if DHCP is working on router, but i guess yes because all computers have default IPv4 8192.168.1.- and yes the 3rd computer is connected via cable. –  Diogo Oct 5 '13 at 18:38
1  
This question appears to be off-topic because it is cross posted on ServerFault as well –  Dave M Oct 5 '13 at 18:47

2 Answers 2

Some knowledge that is helpfull to solve your problem:

I made it that detailed, so that you are probably able to solve problems like that by your own in the future.

Your internet service provider (ISP) is providing only one IPv4 address to you, that is routeable [A] on the internet. (Connect to whoer.net to see this IPv4). Now the problem is, that you only have one address, but multiple computers, you want to connect to the internet. The solution is, that you have a router for your own, that gets your one public IPv4 address. However, now your router has an IPv4 address, but your computers not. So here comes the trick, your router creates a network on its own, called subnet, to provide addresses to your computers. These addresses are not routeable through the internet, because everyone can assign these private subnet addresses to their computers (network interface controllers). The most common network that a router creates by default is 192.168.1.0/24 [B].


Every computer, connected to your router, gets an IP address assigned out of the subnet, so does your iMac. Your Windows OS, running in a virtual machine is different by default, because your virtual machine host program (Parallels) acts like a router and creates another subnet for the virtual machine guest (your Windows machine in Parallels).

The solution to your problem is to change the network settings of Parallels from NAT to Bridged Ethernet Networking.

I for myself don't have a copy of Parallels, but I have found a pretty good article. It is written German, but you should get it with Google Translate and by the many pictures that are in the article.


[A] Routeable in this case means, that the routers on the internet accept this IPv4 address as legal and know in which direction they have to send the packets to. For more details listen to Steve Gibsons explanations at SecurityNow! Podcasts 25, 26, 27.

[B] (The /24 means, that you are only allowed to choose the last number of the IPv4 address on your own. By default your router chooses 192.168.1.1, so that you have the choice from 192.168.1.2 up to 192.168.1.254 [192.168.1.0 and 192.168.1.255 are not free to assign them to your computer. The /x is know as subnet mask and can also have the form xxx.xxx.xxx.xxx (255.255.255.0 for /24). /24 because 24 bits are already set and you are only allowed to choose the last 8 bits, behind the third period.

PS: This text does not claim to be exact in all details, to be more readable to novices. If you nevertheless think, you can provide more detail, without losing the readability that's left, please commit changes!

share|improve this answer

The simplest solution to your problem is to set up your VM guest to be connected via a Bridged Network.

In Parallels, you accomplish this as follows: with the VM turned off,

1) Virtual machine Menu -> Configure -> Network Adapter. 2) Check Enabled, Connected and Bridged Ethernet. 3) Select Default Adapter. 4) Choose OK. 5) Start your VM.

Now, from within the guest VM, ipconfig will show you the IP address to be within the subnet 192.168.1.0/24, and the printer will be accessible to the guest VM.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.