Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I reinstalled vlc and deleted my preferences, because it was bugging out a lot. Now, I have a weird problem. In the windowed mode, volume display goes up to 200%. But, in fullscreen mode, it goes upto 100% only.

So, if I have to increase the volume above 100% (say for video with very low volume) it displays the full bar. Previously, it used to display the bar upto the maximum limit (200% in my case). Now, it gets extremely annoying to see full bar, even if volume is half of the limit. I remember there was a setting to change this; but I can't find it now.

What am I missing here?

share|improve this question
Never seen this behaviour before. What OS, and you are using the latest VLC (2.0.8 for windows)? – Darius Oct 6 '13 at 9:30
Hi, Sorry forgot to add that info. I am using VLC 2.1 and Windows 8. Previously I was using 2.0.8. In previous version, the bar was 0-maxlimit. Now, it just displays 0-100%. – jitendra garg Oct 6 '13 at 9:39
That.. is interesting. I have heard how VLC has been accused of destroying speakers when they had that 0-200% volume bar. Looks like they learn from there and only have 0 - 125% volume bar now. But for me, it only have 0-125% for both windows, and full screen. Can you double check? – Darius Oct 6 '13 at 10:16
Yes, I double checked. In settings>main interface>qt, there is an option to change the display limit named "maximum volume displayed". It was set to 125% by default, and I changed it to 200%. But, the fullscreen OSD was always set at 100%. The limit goes to 125% by default, but the OSD shows upto 100%. Earlier, it used to be same as the bottom right display in windowed mode. – jitendra garg Oct 6 '13 at 11:20
I'm .. not quite sure you managed that to be honest. I did find the same setting, but to change it I actually need to run VLC as administrator - change the maximum volume under Qt - and then restart vlc before it will actually show. But in my case it shows on both windowed and full screen. – Darius Oct 6 '13 at 11:55
up vote 1 down vote accepted (wontfix)

Despite being inconsistent with the GUI volume and in a sense even with itself, this is the new "expected current behavior" for the OSD's volume feedback. Your choices are to configure the GUI volume to also stop at 100% and maybe also configure that that your true maximum volume, or accept the dissonant and less useful feedback.

There is no configuration at all for the OSD's volume behavior.

Alternatively, you can go back to version 2.0.8 [ ] which was the last version (with a windows release at least) to show a bar in the OSD representing the full range of volume. It's a mixed bucket however, as newer versions do seem to offer better overall audio quality and linearity of perceived volume (at least in my configuration).

In either case, you will most likely find frequent need to use volume levels well above 100%. I find in 2.0.8 that for most videos 100% volume is a just-adequate baseline volume for a very quiet room. In newer versions that baseline is closer to 85%, but it's still quite normal to need up to 150% and that's not even competing with other loud noises.

Using standard compression and/or preamp instead may give you adequate volume range between 0 and 100% (which would let you limit to that range and configure GUI and true limit to stop at 100 and at least be consistent and intuitive), but likely at the cost of dynamic range and/or audio quality even on audio that would not need to be amplified past 100% in the first place. It depends on your needs. I use compression to explicitly reduce dynamic range as I've no interest in being bombarded with loud noises nor straining to hear. I'd far rather have consistency, and theatrics or mood be dammed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.