Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently installed Linux Mint 15 on VirtualBox on a Windows 8 host. Everything seems OK, but I have severe problems with performance of Firefox on it. Sites display with delay and the keyboard input is horrible, I can write the whole query string in Google yet nothing is displayed in the browser (I use the website search engine, not that included in Firefox). Other program seem to work properly, although I just tested few of them that I really need (like terminal, Sublime Text and Firefox).

What's even stranger is the fact that I've installed a Windows 7 guest on another virtual machine with exactly the same specs and it works perfectly, no lags an problems. What can I do to fix this? Also, are there some tricks to make my Linux guest work smoothly?

The specs of my laptop: Intel Core i7-3610QM 2.30GHz, 16GB RAM, NVIDIA GeForce 660M on x64 Windows 8. And each of the VMs has this configuration: 8192 MB of RAM, 8 virtual processors and 128 MB of video memory.

share|improve this question
    
(1) Have you installed the vbox guest additions for Linux? virtualbox.org/manual/ch04.html#idp52375472 (2) try disabling cinnamon/compiz effects: forums.linuxmint.com/viewtopic.php?f=90&t=122230 (3) I think there is a setting to enable 3D acceleration for the graphics card? You can enable it in the settings of the virtual machine (under display settings?) –  medigeek Oct 6 '13 at 9:54
    
(1) and (3) I've done it already without any effect. I've tested also (2) - no result, still huge lags when entering anything in Firefox from the keyboard. –  Tomcatus Oct 6 '13 at 11:06

1 Answer 1

up vote 1 down vote accepted

1) Try to increase the virtual video memory to 1024mb (or set to max, can't remember the maximum allowed size) and lower the virtual RAM memory accordingly.

2) Some users have had similar problems: http://forums.linuxmint.com/viewtopic.php?f=49&t=119695

I had same problem running Min13 64 on a windows xp x64. The problem was related to chipset and audio controller used during virtual machine creation. Now using PIIX3 and ICH AC97 and after reinstalling Mint, both video and audio works smoothly

I had the same problem with xfce version. It turned out to be a simple mistake - I've chosen Ubuntu as OS option while creating VirtualBox machine. Once I recreated it with Ubuntu64 and reinstalled Mint, everything became fast and nice (2G on 1 CPU). No need to install additions either as they appear to be included with the distro.

3) There's a tutorial to make firefox faster: http://community.linuxmint.com/tutorial/view/338

Before making any changes, please make a backup of .mozilla/firefox/--------.default/prefs.js for your own safety. prefs.js is a file that stores all of your history and bookmarks from Firefox.

First open Firefox.

Type "about:config" (without quotes) in the Firefox address bar and then click "Enter". This command opens a configuration page that allows the user to change advanced system settings in Firefox.

Speed up page loading/rendering time in Firefox. Right-click anywhere in the "about:config" window, click on "New" and then select "String". Name the string "nglayout.initialpaint.delay" (without quotes). Enter a value of "0" and then click "OK". This tweak decreases the amount of time Firefox waits to render a page from 250 milliseconds to zero. Make the same process and name the string "content.notify.interval" and enter a value of "0".

Force Firefox to release reserved system RAM when the browser is minimized. Right-click anywhere in the "about:config" window, click on "New" and then select "Boolean". Name the entry "config.trim_on_minimize" (without quotes). Change the value to "True" and then click "OK". This setting forces Firefox to only reserve about 10 MB of system memory while minimized.

Normally Firefox only sends one or two tunnels to the website. However, the more tunnels you use the faster you go. To change this, type in filter bar "network.http.pipelining.maxrequests" and change the value to "150". Attention: The more tunnels you use, the more bandwidth you use, meaning you could use as tunnels as you want but that would probably kill the sites bandwidth if everyone did that. 150 is a very good value.

Type "network.http.pipelining" in filter bar, and set it to "True" by double clicking it.

Type "network.http.proxy.pipelining" in filter bar, and set it to "True" by double clicking it.

4) Also try to backup your firefox settings and reset your Firefox to default:

In short, head to about:support (or from the menu Help > Troubleshooting Information) and hit the reset button. You will have to reinstall your data and extensions.

share|improve this answer
    
Thank you very much. The problem was in wrongly set OS option when creating my virtual machine - now I've chose Ubuntu 64 and installed and it works just smoothly. Also after applying those instructions on making firefox faster it works even faster than on my host. Thank you very much :) –  Tomcatus Oct 7 '13 at 18:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.