Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Disaster, Please, Help ASAP.

I had a dual boot on my pc with windows xp and lubuntu linux. Then recently i had some windows errors and decided to install windows 8 instead of xp.

So after i reinstalled windows i installed grub, in order to boot my old linux like this:

sudo mount /dev/sda5 /mnt /dev/sda5
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt
grub-install /dev/sda

And this is what fdisk -l shows:

device     boot   id   system
/dev/sda1  *      7     HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2         7     HPFS/NTFS
/dev/sda3         f     w95 Ext'd (LBA) <- used to be D: disk, not yet mounted
/dev/sda5         83    Linux
/dev/sda6         82    Linux swap / Solaris

And this is what i get when i boot linux:

begin: running /scripts/local-premount ... resume: libgcrypt version: 1.5.0 resume: could not stat resume device file '/dev/sda7' and it says press enter to start system or something like that.

My guess is that something went wrong with swap partition. I am not an experienced linux user, so please provide as detailed instructions as possible.

share|improve this question
What was on the missing partition /dev/sda7? The boot process is looking for something on that partition, and it's not listed in the fdisk output. – M K Oct 6 '13 at 12:58
Can you somehow access /etc/fstab of /dev/sda5 and print the content? – khajvah Oct 6 '13 at 13:01
I fixed it: sudo apt-get purge hibernate, i cant answer my question yet because of low reputation ))) – Benedictus Oct 6 '13 at 13:15
up vote 0 down vote accepted

Solved it with : sudo apt-get purge hibernate

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.