Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am attempting to set the default program to open a file with and I am unable to do so. I am using Windows 7 and the file extension I am attempting to set a default program to is bfa (*.bfa); the program that not only generates this file type but also the program which I am attempting to set as the default to open it is Blowfish Advanced CS (http://bfacs.sourceforge.net/). When I right click a file and select "Open With", I go through the motions of trying to select the program: clicking "Browse" with "Always use the selected program..." checked and then I browse to the program. Once I select the program it fails to pop up as an option in the "Open With" dialog. I suspect the problem relates to the fact that the OS is 64-bit and application is 32-bit. Any suggestions on how to proceed?

share|improve this question

3 Answers 3

Try

Control Panel\All Control Panel Items\Default Programs\Set Associations

enter image description here

share|improve this answer
    
Thanks, I did try this; it ultimately will end up bringing up the same "Open With" dialog. When I tried it this way it failed as well. –  Gedalya Oct 7 '13 at 17:50
    
@Gedalya can you open the program directly and then the file within the program? and when you choose to open it with your program, what program if any does it try to open the file in? –  barlop Oct 7 '13 at 18:37
    
I can open it directly with my program. Currently the file is associated with Adobe Acrobat; this is by accident though. When I first installed the program the file type was unassociated; when I tried to associate it it was accidentally associated with Acrobat. –  Gedalya Oct 7 '13 at 18:58
    
so was acrobat always opening it? and you couldn't stop acrobat from opening it until you change the file association within blowfish itself? –  barlop Oct 7 '13 at 20:35
    
No, Acrobat wasn't always opening it. I associated the file with Acrobat on accident; I went through the motions of trying to associate Blowfish and didn't pay attention to the fact that it wouldn't let me and Acrobat was selected so it ended up being associated. Acrobat doesn't really have anything to do with the problem. –  Gedalya Oct 7 '13 at 21:41

I was able to fix my problem with the program itself. See the picture below for reference; under 'Tools' > 'Options'

The 'Miscellaneous' tab; under 'Registry Setup' there are two options that alter the registry. I applied both and it works now. What isn't clear is how I could have done this without the program doing this.

enter image description here

share|improve this answer
    
you can accept your own answer –  barlop Oct 8 '13 at 21:48

I had the same problem, and none of the solutions worked (like the above method of going to the Control Panel - which does the same thing if you right click the file->Open With->Choose Default). Even after selecting the new program many times, it was stuck with the old one.

I fixed it by editing the registry. Go to the concerned extension like this (I had problem with .cpp):

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.cpp

Besides these two keys: OpenWithList and OpenWithProgids, it might have a third one called 'UserChoice'. Just delete that third key. After that, it will allow you to change the default program for that file extension.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.