Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I dont know why, but suddenly many applications in my computer can't start. For example Chrome Portable shows this error on execution:

NSIS Error

Error writing temporary file. Make sure your temp folder is valid

Many other applications just show a Windows error reporting on execution.

Fortunately I had created a Norton Ghost image from the C drive four months ago (when I had absolutely no problem), but after a successful Windows restore, the problem is still the same! Google Chrome is still showing the error above and the other programs still can't be executed.

I searched whole internet for the reason. Most say it's a problem with the %Temp% folder permissions. I took ownership of the folder, set Temp folder owner to "Administrator or the current user", full access for "Admin" and "current user" and "Users" profile, but still it's the same! I have also done these to C:\windows\Temp folder.

I even cant execute "Process Monitor" to monitor the problem!

I even changed both %Temp% and C:\windows\Temp folders paths to c:\Temp but the problem is the same.

It seems many programs can't write files in Temp folder, but I see "Firefox Portable" can do that!

Specs: Win 7 32bit Ultimate SP1

I installed a new fresh windows 7 yesterday, but the problem is still there! i found something interesting: If i move Chrome Portable directory to upper roots of F drive, the program will start normally!! it seemes that windows has problems with specific paths, for example most of the applications on F:\programs\Install on my computer cant access Temp and result in error. i checked Permissions on F and Install folder, everything is just like other drives. some said use ICACLS F:\ /setintegritylevel H but it does not change anything. for now, the only way to get ride of this problem is to downgrade to Win XP so no Permissions and other damn security stuff won't work. please help me out of this headache.

share|improve this question
If taking ownership of the folder does not solve the problem ( horrible idea this shouldn't be required unless your entire system's permission system is toast ) and even it was toast a restoration of a previous backup would resolve the problem. So it sounds like your backup wasn't what you think it was. – Ramhound Oct 7 '13 at 18:51
i'm absolutly sure the image is for 4 months ago as its modification date is 4 months ago, desktop icons are less (because desktop icons grow by the time lol :D) and the anti virus database is dated 4 months ago. i'm really surprised too that image restoring didnt worked. i think file permission settings are stored in another place than the windows drive. but where?! – Alireza Oct 7 '13 at 19:49

If you run a program (that is you, as in your account, not the OS/System) then I 4expect it to write to your temp folder. By default that is %osdrive% (aka C:) /users/username/AppData/local/temp.

YOu can verify that with starting cmd.exe and typing echo %tmp%

This should be different from the OS tmp files! Else a user could mofify files in the OS tmp files and compromise the system.

share|improve this answer
i didnt get what you said but i checked echo %tmp% in and it was pointing to c:\temp (as i changed default temp path, its poining to the currect path) – Alireza Oct 7 '13 at 19:52
Do you have rights to write to C:\temp. (Where 'you' is 'your user-account'). – Hennes Oct 7 '13 at 19:58
yes current user and Admin both have full access to C:\temp – Alireza Oct 7 '13 at 20:02

Here's what happened to me and what I did.

I couldn't install anything.

  1. Made a new local admin user - logged on tried install - same temp file access error.

  2. installed windows updates and ran malware bytes to see if some sneaky process had taken control - no change.

  3. Made myself owner of %USERPROFILE%\appdata\local\temp (c:\users\yourname\appdata\local\temp) - no change

  4. I then tried deleting the accursed temp folder but 'no go' even in safe mode.

So I left it and created a new folder in the same location called tmp

Then I changed the install paths

(right click my computer / advanced system settings / advanced /environmental variables)

edited temp to %USERPROFILE%\appdata\local\tmp and (similarly) tmp to %USERPROFILE%\appdata\local\tmp

Installs started working again - it looks like temp folder was either corrupted or in control of some other process that wouldn't let it go....


share|improve this answer
...For what it's worth, in my case, I suspect it was actually dropbox that caused me to loose access to the folder... – user510132 Oct 16 '15 at 9:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.