Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I try to use Unicode characters in file names. It is possible to use them, if I copy the character into the clip board and paste it into the file name. But I did not manage to enter them directly via the keyboard.

I enabled the hex numpad registry key:

[HKEY_CURRENT_USER\Control Panel\Input Method]
"EnableHexNumpad"="1"

But when I try to use it I never get the character I want to. I tried it also with several browsers at the browser test page but nothing works. When I enter Alt+++2222 I get a black smiley instead of the spherical angle.

How can I use a Unicode character in a file name by renaming it with the Windows explorer?

share|improve this question
    
This sounds odd, because “☻” is what you get by simple Alt 2 without using the + key (with or without the registry setting), but only when you release the Alt key. So this is not just a matter of the registry setting not taking effect (regarding which: you closed the registry editor and rebooted, right?). –  Jukka K. Korpela Oct 7 '13 at 19:56
    
A look at a related post might be helpful: superuser.com/questions/287451/… It explains some potential pitfalls. –  Axel Kemper Oct 7 '13 at 20:12

1 Answer 1

You could use the Windows tool %windir%\system32\charmap.exe to enter special characters and to get to know their Unicode codes. Charmap displays the Alt+ combination of the selected character.

enter image description here

There are also free tools like BabelMap available, if charmap is not flexible enough.


Your method (and others, including a special input tool) are described here:

Text copied for convenience (to help you find out what went wrong):

This method works regardless of any of your language settings, but is the most cumbersome to type.

  1. Press and hold down the Alt key.
  2. Press the + (plus) key on the numeric keypad.
  3. Type the hexidecimal Unicode value.
  4. Release the Alt key.

Alas, this appears to require a registry setting. It was already set on my computer, but some readers report that this method didn't work for them, and this is probably why. If you don't know what the registry is, please don't try this. Under HKEY_Current_User/Control Panel/Input Method, set EnableHexNumpad to "1". If you have to add it, set the type to be REG_SZ.

share|improve this answer
1  
The first part is irrelevant to the question. The second part might make the approach in the question more explicit, or explain it, but it does not address the question. –  Jukka K. Korpela Oct 7 '13 at 19:46
    
My intention is to enter the character with the keyboard. –  ceving Oct 8 '13 at 8:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.