Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I attempt to traceroute to an IP Address, I only get a single hop for output.

Traceroute has started…

traceroute to 8.8.8.8 (8.8.8.8), 64 hops max, 72 byte packets
 1  google-public-dns-a.google.com (8.8.8.8)  44.084 ms  79.168 ms  54.720 ms

This happens regardless of what I enter, dns names, routers, etc. I see the same thing if I run mtr. I doubt that I am one hop away from every point on the internet.

Is there some setting I am missing?

Update

I am running a media link wireless N router (model MWN-WAPR150N) connecting via N, which connects to the Cable company router, from there it is coax out to their hop.

I agree something is intercepting

share|improve this question
2  
Interesting. Can you edit and add details about your connection - what sits between you and your ISP? Even if Google had a node at your ISP, there should be more than one hop. It looks like your router is intercepting traffic to 8.8.8.8 and replying on its behalf - except the latency looks right for their servers. –  Paul Oct 8 '13 at 4:39
    
Some third party firewalls do this. I know ZoneAlarm did it on Windows for example. Can also try another packet type, traceroute 8.8.8.8 -I –  Brian Oct 8 '13 at 9:02
    
@Brian that is an invalid option, I am in OSx. I did notice that changing networks appeared to change the output. So I think it is more than likely the medialink router. Once I get home again, I will need to see fi there is a way to change the output. –  Geoff Lanotte Oct 8 '13 at 13:03
    
@Paul I did update with those details. –  Geoff Lanotte Oct 8 '13 at 13:05
    
Do you have another machine you can ping from? –  Paul Oct 8 '13 at 13:09

1 Answer 1

Try something besides the google DNS. Google's DNS uses anycast, which the over-simplified version of is that they have servers answering that address all over the internet, and anycast picks the closest one. They might just have DNS at your ISP. Picking another address should get you something more normal looking.
If not, then something weird may be going on.

share|improve this answer
    
That I did, I tried my personal domain hosted on Digital Ocean, I get the same result whether I ping the IP directly or use the domain name. –  Geoff Lanotte Oct 8 '13 at 5:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.