Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having problems with Varnish.

Here is the relevant portion of the log

2013/09/29 06:24:54 [warn] 2680#0: the "user" directive makes sense only if the master process runs with super-user privileges, ignored in /home/vb/plumi.app/templates/main.conf:11
2013/09/29 06:24:54 [emerg] 2680#0: bind() to 0.0.0.0:80 failed (13: Permission denied)

So, someone suggested I restart Varnish as root.

To do that, I'm trying to follow the instructions from the Varnish Wiki which say to do something along the lines of:

# varnishd -f /usr/local/etc/varnish/default.vcl -s malloc,1G -T 127.0.0.1:2000 -a 0.0.0.0:8080

I'm not sure how to modify this above instruction to fit my specific situation, nor am I sure in which path location I should run the above command.

I've tried various modifications, and various paths, and each time I run varnishd I get the following error:

The program 'varnishd' is currently not installed.  You can install it by typing:
sudo apt-get install varnish

I get this same above error even when I run varnishadm anywhere to see if varnish is running.

I'm pretty sure varnish is already installed (see below), but I'm willing and happy to reinstall varnish if I knew the correct place to install it.

I'm giving below my directory locations for varnish, varnishd and varnishadm

vb@ubuntuvb:~$ sudo find / -name varnish
[sudo] password for vb:
/home/vb/plumi.app/parts/varnish-build/etc/varnish
/home/vb/plumi.app/parts/varnish-build/var/varnish
/home/vb/plumi.app/parts/varnish-build/include/varnish
/home/vb/plumi.app/eggs/plone.app.caching-1.1-py2.7.egg/plone/app/caching/proxy-configs/varnish
/home/vb/plumi.app/eggs/plone.recipe.varnish-1.3-py2.7.egg/plone/recipe/varnish


vb@ubuntuvb:~$ sudo find / -name varnishd
/home/vb/plumi.app/parts/varnish-build/sbin/varnishd


vb@ubuntuvb:/usr/sbin$ sudo find / -name varnishadm
/home/vb/plumi.app/parts/varnish-build/bin/varnishadm

Please give me an exact command that I should use to start Varnish, and also suggest the path at which I should enter the command.

Thanks!

share|improve this question
    
How were you trying to start varnish as a user in the first place? –  Jan Hudec Oct 8 '13 at 8:31
    
Where is your varnish installed and why are you not using the packaged version? Unless you have really good reason, you should be using the packaged one. It is easier to update when security problem appears and it comes preconfigured to automatically start as root correctly. –  Jan Hudec Oct 8 '13 at 8:33
    
Thanks for your comments. I was trying to follow the instructions for installing Plumi (a video CMS). The instructions are here: github.com/plumi/plumi.app/blob/master/docs/INSTALL.rst –  user1883050 Oct 14 '13 at 5:25
    
Those instructions don't say anywhere to install varnish manually. So the question stands. Why are you not using the packaged version? –  Jan Hudec Oct 14 '13 at 6:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.