Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I received a hard drive for a boot partition. I copied the old partition over using DiskCopy. After the copy, the computer would not boot with both drives in and the new drive as the primary; instead the computer reboots after posting endlessly. Nothing comes up after post, it immediately reboots. The drive seemingly works as a non-boot drive though in both the computer in question and another.

So here goes on what has been done.

Used windows recovery mode to fixmbr and fixboot. Put the drive into a linux box, and noticed it was NOT flagged as bootable, so I flagged the drive as bootable, then fixmbr, then fixboot again Checked boot.ini and it showed the correct drive and parition and other settings. Set the only BIOS setting pertaining to hard drives for performance to "Bypass". No change. Switched drive back to secondary and put old drive as primary, computer rebooted like normal from old drive. Chkdsk new drive with /f switch, chkdsk finds a free space discrepancy with the MFT and fixes it. Fixmbr and fixboot again, still reboots after post like nothing has changed. Tried booting with just memory, CPU and HDD (minimum power usage); no change. Booting from the old drive with the new drive as a secondary gives the boot selection that only shows the old drive install which starts normally.

The computer is a Dell E310 and about 7 years old; The drive is a 160GB WD Raptor HLHX drive. Not sure if the drive would be too advanced for a basic dell computer of this age; I doubt it.

Bought listed as new on ebay. The drive arrived in a non-crinkled anti-static bag with a orange sticker that had not been tampered with. Not sure if it is actually unused and "new", but appears to be so. It definitely works much faster than the old drive meaning it isn't having read errors or any thing during use.

Also, the computer doesn't seem to be showing any signs of hardware failure. It functions perfectly normal until the new drive is put in as a primary drive and then boot from. Put the drive as secondary and boot from the primary and all seems well again.

So it's obviously something with the drive. but what?

The drive seems to function COMPLETELY normally in linux and windows (when it is not a boot drive). Loader files in the root are exactly (to the byte) the same size old to new. and the boot.ini's are identical. Also, with a fixmbr and fixboot, theoretically even there boot sectors are identical.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Well, as I developed this question, I solved it as well.

Linux to the rescue of Windows was the solution. Using Gparted, I analyzed the partitions to look for any differences as the partition was technically a "sector-by-sector clone".

Turns out they were the same, EXCEPT the starting sectors were different. The starting sector of the Windows parition on the old drive was 2048; the starting sector on the new was 63.

Well, I deleted the partition and re-cloned using gparted making sure they started at the same sector and marked the partition as bootable after the clone finished. Voila!, Windows started right up! Sheesh.

Anyone have insight into why this was the problem?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.