Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can type [ and { with no issues, but when I type ] nothing happens, and when I type } a ? sign is typed instead. This is an issue only while in Terminal or Emacs (Terminal and GUI).

Everything works fine while in UnitedStates keyboard language mode. This problem is exclusive to Español - ISO and Español kayboard language mode.

This is my keyboard: My Keyboard

The ] sign is in alt + +. The } sign is in alt + ç. These are the ones that are not working.

What can I do to fix this? I need them to work in Español - ISO or Español kayboard language mode.

share|improve this question
1  
When I tried using the "Spanish - ISO" input method in Terminal, I couldn't type |, @, or # either. –  Lri Oct 9 '13 at 14:40
1  
Have you looked into using the key translation map? –  lawlist Oct 11 '13 at 14:21
    
@lawlist Yes. The characters are there. I know where they are and I can type them without problem outside of Terminal and Emacs. –  JCPedroza Oct 12 '13 at 7:44
    
How about something simple like this?: (global-set-key (kbd "M-v") (lambda () (interactive) (insert "✓"))) You can use it to insert anything. YASnippet is a package that could also be used to insert something. –  lawlist Oct 12 '13 at 15:34
    
@lawlist That seems that might work for emacs, but the problem will still persist through terminal. –  JCPedroza Oct 13 '13 at 1:21
add comment

2 Answers

Dunno whether this helps, but there are lots of google hits for this and similar questions. Here is one answer, which might help if you are on an Apple computer:

OK, then open the International preference of System Preferences.
Click on the Input Menu tab (rightmost tab.) Check the box to display the Keyboard
Viewer.  You should now have a menu bar item for the Keyboard Viewer. When you
select, it should open the viewer so you can find the location of the keys for the
brackets.

Another answer for a Mac says to use Alt+Shift+) for ]. Dunno whether that will help you. Good luck.

share|improve this answer
    
Thanks for your help! The first suggestion doesn't work for me, since I need to be able to input the characters from my keyboard. The second suggestion is not working. –  JCPedroza Oct 12 '13 at 6:54
    
I know where the characters are. I can type them outside of Terminal and Emacs. The problem is that I can't type them while on those programs. –  JCPedroza Oct 12 '13 at 7:45
add comment

Emacs auto-pair might be what you're looking for. It's specific to your need.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.