Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the following problem:

I'm using Eclipse with the Subclipe SVN plugin installed. When I update the sources outside of Eclipse, (e.g. doing a svn update in the working copy) and a "refresh" in Eclipse, all the sources seem to be not under version control anymore. They all got a Questionmark and the "add to version control..."-option. When I try to do an Update or some other subversion operation, I get the following error message:

org.tigris.subversion.javahl.ClientException: svn: '/home/tim/workspace/myproject' is not a working copy
svn: Cannot read from '/home/tim/workspace/myproject/.svn/format': /home/tim/workspace/myproject/.svn/format (No such file or directory)
org.tigris.subversion.javahl.ClientException: svn: '/home/tim/workspace/myproject' is not a working copy
svn: Cannot read from '/home/tim/workspace/myproject/.svn/format': /home/tim/workspace/myproject/.svn/format (No such file or directory)

When I disconnect the project and share it again, everything is back to normal. I guess this could be a version conflict between the integrated Subversion SVN lib and the svn-command version, right?

So my question is: How can I get this back to work properly?


Eclipse 3.5.1 Subclipse 1.4.8 Subversion Client Adapter 1.5.3 Subversion Native Library Adapter (JavaHL) 1.5.7 SVNKit Client Adapter SVNKit Library

svn, Version 1.6.5 (r38866) Aug 31 2009, 18:42:02

lately updated to Ubuntu 9.10 Karmic

Just checked in another workspace. When I do a svn update, the file called "format" gets deleted.

As jor pointed out, the problem was a version conflict. I had already tried to find updates in eclipse, but that didn't worked out, because subclipse changes the update site for every point release. As you can read here:

The recommended procedure to upgrade Subclipse to a new 1.x to 1.y release is to follow the first-time install instructions. Enter the update site URL for the new release stream into the Eclipse update manager and this will install the new version on top of your existing installation. This process works more reliably than asking Eclipse to check for updates.

share|improve this question
up vote 1 down vote accepted

yes, you need to upgrade your subclipse plugin & svn connectors, either javahl (1.6.x) or svnkit (1.3.x) so they match support your installed subversion (1.6.5). See the project site for the upgrade site URLs if you don't have these already.

Or downgrade your ubuntu subversion package, but I would not recommend doing that.

share|improve this answer
Ya, that helped! I already searched for updates, using eclipse but it didn't found them. You have to add a new update site for every point release. – Tim Büthe Nov 5 '09 at 10:33

The situation was I was working on a file that someone else deleted under SVN version control. Thats fine as I was only superficially modifying the unit tests in that file.

Under eclipse I syned and updated which deleted the file in question.

Subsequent use of SVN under eclipse indicated that the file under question no longer existed in version control. Thats fine as it appeared to no longer exist on my file system. So why was it complaining?

The file wasn't on my file system but "svn update" kept complaining the file is not under version control:

svn update
svn: 'blah blah blah...' is not under version control

The fix to this problem (and this was a nfs like filesystem) was to flush file system buffers then an svn update. The update did succeed:

svn update

The sync flushes file system buffers the problem was solved.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.