Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows 7 laptop takes 1-2 minutes to connect to a wifi network. As a college student, my laptop goes in and out of sleep multiple times throughout the day. Having to wait a few minutes for internet each time I open it is getting annoying.

This happens when connected whether or not the power cable is plugged in.

share|improve this question
    
@up yep, don't fix the problem, just throw this away and give a bunch ones to yourself free! Damn, thats good... –  Tomcatus Oct 9 '13 at 7:36
1  
More information is required. Are you allowing Windows to manage your wireless connection or using third-party software to do it? –  Ramhound Oct 9 '13 at 11:44

5 Answers 5

EDIT: I'm still experiencing the same problem with this service enabled and running

Found the answer here

This is for XP/Vista,but hopefully ,7 will be similar.

You would be looking for wlan/or wzc AND some d-link wireless manager manager associated with the wireless card running simultaneously.

Check your Services are Started on all PCs: • COM+ Event System (for WZC issues)
• Computer Browser
• DHCP Client
• DNS Client
• Network Connections
• Network Location Awareness
• Remote Procedure Call (RPC)
• Server
• TCP/IP Netbios helper
• Wireless Zero Configuration (XP wireless configurations)
• WLAN AutoConfig (Vista wireless configurations) This would be the Vista default wireless manager,for example.
• Workstation

Note: You can check the services in Control Panel, Administrative Tools, Services.

All of these services should be started, and their startup type should be automatic (or perhaps manual).

If a service is not running, open it's properties and check the dependencies. Check each of the dependencies and see which one is preventing the service from running. Checking the event log is also a good idea here, there may be clues to what is failing.

For me, it was simply a matter of starting the Computer Browser service and setting it to start automatically.

share|improve this answer

Try to update your network card drivers. But don't through Windows Update but looking for a suitable driver on you laptop manufacturer's website.

Does this happen when connecting to only one wifi network or does it connect with a lag to every wifi network you try to connect to?

share|improve this answer

I am going to assume for the rest of the answer that you only have a 2.4ghz card--as is common in Windows devices (and everything else really). If you do a search for Device Manager in the Start Menu you will be able to look through the list of devices and find your network adapter. Clicking this will bring up a General page and from there go to the Advanced tab. There are your settings. If there is no mention of 5ghz in the settings you don't have a capable adapter.

Since you are at college there is a good chance that this is an WPA Enterprise network (do you enter your uni log in information to connect?) and there are a few caveats. These networks broadcast both on 2.4ghz and 5ghz ranges and provide support for AGN networking. N has the capacity to support 5ghz (is able, doesn't always). I would shut off B if you can in your WiFi driver settings. This might help.

The problem here is that most devices only support 2.4ghz which means that network is very crowded. Schools look to setup connection rules that will encourage 5ghz devices to connect to that range first. This means that most 2.4ghz devices will always connect slower. The problem with this method is that some devices' connection attempts timeout before they can actually connect to the network. You could be in this group. Your computer would then reload the network and start all over.

Do everything else suggested and then look on Amazon for a 5ghz USB network adapter.

share|improve this answer

Turn off power saver on the nic.

For Windows 7 do the following:

  • Click on the Windows Start button
  • In the Search window type "network and sharing center"
  • Press enter
  • In the left pane of the NetWork and Sharing Center select "Change adapter settings"
  • Right-Click your wireless device and select "Properties"
  • Click "Configure"
  • Select the "Power Mangement" tab
  • Deselect "Allow the computer to turn off this device to save power"
  • Click OK

Now the wireless nic will remain powered even when the system sleeps. Keep in mind that this will mean reduced battery life.

If it is still an issue then you can always turn all Power Savers off for the laptop by typing in the Windows-Start-Search "Power Options", then select "Change when the computer sleeps", then for "Put the computer to sleep" chose "NEVER" for "On Battery" and "Plugged In". Hope this helps someone.

share|improve this answer

I had the same problem then I switched off ip v6 in wifi properties and problem solved...

share|improve this answer
    
This answer could be improved by explaining how to do that. –  Kevin Panko Oct 12 at 16:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.