Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a .wmv with the audio codec of wmapro, which my target video player chokes on. I am generally in the process to "standardise" my collection to x264/aac (as this works fine on all my devices), but this particular file gave me big trouble. I tried this:

avconv -i input.wmv -c:v libx264 -b:v 4800k -qmin 3 -qmax 69 -ar 44100 \
       -b:a 128k -c:a libvo_aacenc -ac 2 -pass 2 -y output.mp4

The first pass worked fine, but now I get the message

Resampling output channel count must be 1 or 2 for mono input; 1, 2 or 6 for
stereo input; or N for N channel input.
Can not resample 6 channels @ 48000 Hz to 2 channels @ 44100 Hz

And I googled all morning for this and only found "you got to downmix". I have tried libmp3lame, ac3, acs3_fixed and others, all get me this error.

If there is some options I got to give for this to work, I would very much like to know, as I couldn't find them and was not able to figure it out myself.

Thanks.

share|improve this question
    
The first step is to use a recent Linux build of ffmpeg and see if that does the job. Also, you should always include the complete console output. – LordNeckbeard Oct 9 '13 at 19:15

The best I can think of is get HandBrakeCLI and do the following:

HandBrakeCLI -i file.wmv --preset Normal -o file.mp4

share|improve this answer

I haven't tested it, but it looks like the problem is that you are down-mixing and down-sampling (to 44100 Hz) at the same time. You should first down-mix to stereo @ 48000 Hz, then down-sample (or not).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .