Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In OSX using bash I want to have a symlink inside the webapps folder of a Tomcat server. I have created the symlink using ln -s <source> <target> and also tried with other parameters. Although with the symlink I get the error:

org.springframework.beans.factory.CannotLoadBeanClassException: Cannot find class [...SOLRHelper] for bean with name 'SolrHelper' ...

If I replace the symlink with the actual folder it works fine. Using symlink on the same project works fine in windows.

The symlink points to a directory not a file.

Actual file:  drwxr-xr-x 5 latu staff 170 9 Oct 15:49 com 

Symlink: lrwxr-xr-x 1 latu staff 34 9 Oct 17:45 com -> /Users/latu/CultureGrid/Target/com 

Any feedback on how this might be solved?

p.s I have also posted this on SO although I didnt get any answers.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.