Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While running XAMPP on a staging machine I checked the Apache log file. It shows the following entries:

This is me: Chrome browser

127.0.0.1 ... "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) >Chrome/30.0.1599.69 Safari/537.36"

This is me: Firefox browser on 64-bit Windows 7

127.0.0.1 ... "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0"

And this is the last entry of the log:

127.0.0.1 - - [10/Oct/2013:20:52:03 +0200] "GET /security/xamppsecurity.php HTTP/1.1" 200 >4222 "'http:// localhost/security/security.php'" "Mozilla/5.0 () Gecko/20100101 >Firefox/24.0"

Notice how the Windows NT 6.1; WOW64 part is missing from inside the parentheses in the browser signature. I presume this means it's not the same browser that is being used to access the system. However I am the only person on this computer and I do not have two separate Mozilla browsers.

Can some please explain to me this inconsistency?

Furthermore, I would like to know if there is a way, perhaps by accessing a site on the internet, to display these strings so they correspond to what the browser sends to the web server and display them automatically. That way I can tell which browser sends what, given that there are so many browser versions and types, and they all send different strings.

Thanks.

Thanks.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.