Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have PCs X1,X2,X3 in a network X (Ethernet Lan) all of them in workgroup XW and running windows XP pro 32 bits version.

The same PC X1 is also in network Z (wifi Lan) with another PC Z1 via a wireless router.

I want to remote desktop the PC X1 from my external laptop Y1(in workgroup YW , windows 7 home premium 32 bits) via wirelss wifi network Z.

I have successfully connected my laptop Y1 to network Z.

I made sure that the firewalls on both sides (both PCX1 and Y1) are turned off. And set allowed remote connections at mycomputer > properties > properties page.

After that i enter the name of the PC X1 in remote desktop connection program of Y1 and tried to establish the connection. But i am getting this message everytime i try.

enter image description here

FYI: i can ping the PCX1 from my laptop Y1. I am the administrator so i don't need to set up account in mycomputer> properties> remote desktop .

Any Idea what is causing the problem?

EDIT

Don't know if it is gonna be helpful but i added the network layout with their ip addresses. Red color is network X , blue is network Z.

enter image description here

EDIT 2

I tried using port 3389 like this : 210.2.1.6:3389 but got the same error message as above.

share|improve this question
    
Have you tried doing Remote Desktop using the IP address? –  Darius Oct 11 '13 at 4:00
    
@Darius Yes. It doesn't work either, i used the port 5000 . something like this 210.2.1.65:5000. It should work with full computer name anyway –  Chris Aung Oct 11 '13 at 4:03
1  
Don't remote desktop (default port) works on Port 3389? And about full computer name, that has always been a strange case for me as it takes a while until a computer name is recognized on the LAN for me, so I tend to go with IP address. Eventually the computer name do get recognized, but usually not on my first attempt. –  Darius Oct 11 '13 at 4:10
    
I will give it another try and update the result –  Chris Aung Oct 11 '13 at 4:15
    
Btw does workgroup matter when using remote desktop? –  Chris Aung Oct 11 '13 at 4:19
show 7 more comments

1 Answer

Make sure the username you are using for remote login in PC X1 has a password. Otherwise try changing the password, even if that fails use a different username and password. In the laptop Y1 check if you have set network discovery and password protected sharing on in network properties. Having everything in the same workgroup helps if you are using names, otherwise use the IP addresses. Try these with default port, i.e. without specifying a port.

If the laptop's account is administrator and password is X and the XP computer's account used for remote connection is also named administrator but with a different password, say Y; then you might have errors. Either use same passwords or use different account names when in a workgroup environment. Make sure the computer names on PC and Laptop are also different and unique.

share|improve this answer
    
the PC X1 has password. In laptop Y1, both the network discovery and password protected sharing is on.I also tried without specifying the port like this 210.2.1.6. And the account names are not the same. Computer names are different.. still i can't get it working yet.. –  Chris Aung Oct 11 '13 at 6:33
    
Then may be the RDP version is not compatible, check if you can get RDP 6.0 installed on vista and then try. –  JRulz Oct 11 '13 at 7:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.