Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed OpenVPN in my Centos machine as OpenVPN server. I generated all authentication certificates, keys and all and it worked fine through the key authentication system. I tested it with my VM.

When I used user authentication method, the client gets connected successfully but doesn't have internet connectivity and cant ping to server tunnel. But client still have ping to the client tunnel. I have double checked the iptables in the server. Tried even disabling iptables. But it does not works.

Any suggestions?

UPDATE

Problem solved :)

It got fixed when i changed the line in the openvpn server configuration file from

push "redirect-gateway def1"

to

push "redirect-gateway def"

Anyways..thank u..hope this info will help somebody..

share|improve this question

1 Answer 1

Did you remeber to do

sudo sysctl -w net.ipv4.ip_forward=1 

?

share|improve this answer
    
YEa,,,its not the problem...i have edited the question..anyways..thank you MariusMatuieae –  Unnikrishnan Oct 11 '13 at 6:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.