Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed Debian Wheezy on VirtualBox 4.1.12 (running in Ubuntu 12.04) and have troubles setting the video mode. vga=xxx isn't possible anymore, instead, the video mode should be set using GRUB. In /etc/default/grub I set GRUB_GFXMODE=1024x768 and that works, but when I select to boot Debian, it switches back to text mode 80x25. Setting GRUB_GFXPAYLOAD_LINUX to keep or 1024x768 didn't help.

Any ideas how I could achieve my goal?

share|improve this question
    
Are you using bios or efi for your VM? have you allocated enought video memory for the VM? –  MariusMatutiae Oct 11 '13 at 8:25
    
@MariusMatutiae: I left the default settings, which are BIOS and 12 MB graphics RAM, which should be enough (I never changed that setting and never experienced any problems). –  Michael Kremser Oct 11 '13 at 17:51

1 Answer 1

up vote 1 down vote accepted

To get this to work for me, I followed the instructions in: http://askubuntu.com/a/18463

Steps taken for me

Become root user

su

Open /etc/default/grub.

Find GRUB_GFXMODE= ... and change it to:

GRUB_GFXMODE=800x600
GRUB_GFXPAYLOAD=800x600x32

Edit /etc/grub.d/00_header

Find if [ "x${GRUB_GFXMODE}" = "x" ] ; and change it to:

if [ "x${GRUB_GFXMODE}" = "x" ] ; then GRUB_GFXMODE=800x600 ; fi
if [ "x${GRUB_GFXPAYLOAD}" = "x" ] ; then GRUB_GFXPAYLOAD=800x600x32 ; fi

Find set gfxmode=${GRUB_GFXMODE} and change it to:

set gfxmode=${GRUB_GFXMODE}
set gfxpayload=${GRUB_GFXPAYLOAD}

Run:

update-grub2

Context

I got this working today. I therefore do not know how stable the fix is - in terms of updates being applied to grub or the linux kernel. I hope someone else can clarify whether these settings files every get overwritten by upgrades.

share|improve this answer
    
Using trial-and-error I found out that GRUB_GFXPAYLOAD in /etc/default/grub is being ignored by update-grub. In /etc/grub.d/00_header it is enough to add the line starting with if [ "x${GRUB_GFXPAYLOAD}" and also the line set gfxpayload=${GRUB_GFXPAYLOAD}. –  Michael Kremser Oct 11 '13 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.