Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I realize that getting an answer to this question is a long shot, but I have been wrestling with this for three days so far with no luck.

I recently installed a new DSL Modem/Router sent to me by my ISP (Frontier), model NetGear B90-755044-15. I made no major setup changes, although I did enable WIFI, disable SSID broadcast, enable Mac authentication and set up WPA encryption. I have the Firewall set to OFF. I do not have port forwarding or NAT configured in any way, although that really shouldn't matter. I have confirmed (repeatedly) that I am using the right IP addresses, that all machines and devices are on the same subnet, and they all use the same default gateway.

Since setting up this new modem/router I have been unable to access IIS on one of my wired machines (LAPTOP) from anywhere on the local network. LAPTOP is running Windows 7. I can access IIS on LAPTOP using "localhost/..." so I know the service is running.

I can access IIS on another machine (FILESERVER) which is also connected to my local network. FILESERVER is running Win 2k3. FILESERVER is plugged directly into the router, while LAPTOP is plugged into a switch which links to the router. I tried connecting LAPTOP directly to the router as a test, but that did not change anything.

Next, I activated IIS on another machine (DESKTOP) as a test and I get the same outcome- I can access IIS through "localhost/..." on DESKTOP, but I cannot access it from any other machine. DESKTOP is running Windows 7.

FILESERVER and LAPTOP both have IP Address allocation set to static, while everything else on the router is DHCP. I can ping every machine from any other machine on my network successfully. I can telnet into FILESERVER 80 from any other machine, but not to any other machine. (telnet services are enabled on LAPTOP, DESKTOP, and FILESERVER). Interestingly, within the router's "My Connected Home" page I can also choose to "Access Device" for FILESERVER, which launches a new tab to the IP address and the default web page there.

I have tried resetting the modem to factory, but it immediately comes up with the same results- I can access FILESERVER but no others. Frontier customer service was no help (as I expected) and Netgear won't assist unless I shell out $80 for their premium service...with no guarantees they can figure it out for me.

Again, I realize this is a long shot but I am at my wits end. I am hoping someone with a lot more Network experience can see something obvious that I am missing.

EDIT: I am only using the local network address: 192.168.xxx.xxx/WebServiceName and 192.168.xxx.xxx/WebServiceName/WebServiceName.svc. I am not trying to make the service available outside of my home network because I only need access for the purpose of testing. I have not tried to do any port forwarding- I didn't think I needed to for internal addressing.

share|improve this question
    
What address are you using to acess the IIS server the local network address that is only valid within your network or your public address? Furthermore have you tried to forward the assigned IIS port to your server? –  Ramhound Oct 11 '13 at 16:01
    
I am only using the local network address: 192.168.xxx.xxx/WebServiceName and 192.168.xxx.xxx/WebServiceName/WebServiceName.svc. I am not trying to make the service available outside of my home network because I only need access for the purpose of testing. I have not tried to do any port forwarding- I didn't think I needed to for internal addressing. –  William Smith Oct 11 '13 at 16:08
    
Update your questin to reflect that fact and include the information you just provided. Additionally have you tried to ping the IIS server internal lan address? –  Ramhound Oct 11 '13 at 16:12
    
Comments appended. I am able to ping every machine on the network from any other machine. –  William Smith Oct 11 '13 at 16:26

1 Answer 1

up vote 0 down vote accepted

Since setting up this new modem/router I have been unable to access IIS on one of my wired machines (LAPTOP) from anywhere on the local network. LAPTOP is running Windows 7.

Double check the Windows firewall settings, it may have spotted the new router as its source for address configuration via DHCP and decided that you've moved networks. It should prompt you when this happens and ask what sort of network you are attached to, but I've seen it instead silently set itself to behaving like it is on a Public (rather than Work or Home) network and by default the Public profile switches the firewall to be fully paranoid (block everything incoming) and turns services like file sharing off.

If this has happened, flipping the setting back from Private to Home/Work should revert things back to as they were previously.

If the new router uses a different address range (some use 192.168.1., some 192.168.254., and so forth) and your firewall rules were set to allow a specific range (rather than being set to "local range" or "everything", which is more usual) then they may need tweaking too to reflect the new subnet.

share|improve this answer
    
I think you have given me what I need! The old router was on subnet 192.168.1.x while the new one is 192.168.254.x. Unfortunately, LAPTOP is my work PC- and the firewall is strictly controlled by group policy even for development machines! So over on DESKTOP (my personal machine) I switched the firewall off as a test. I am now able to access IIS on DESKTOP from other machines on my network. So is there a way to refresh the network settings on LAPTOP so the firewall won't block me? I tried restarting and also ipconfig /flushdns with no luck. –  William Smith Oct 11 '13 at 17:05
1  
You can almost certainly reconfigure the new router to use the other address range - so if it was happy before it should be happy again. –  David Spillett Oct 11 '13 at 21:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.