Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here is my setup:


I have installed XAMPP as Administrator and am running it as Administrator. I have an entry in my Windows 7 hosts file listing "127.0.0.1 rainbow.com" as the fictitious domain which I am using on my development machine. I configured an admin user in the BitNami Magento module for XAMPP named johndoe@rainbow.com . I have added this user in Mercury via:

XAMPP Mercury Admin Button -> Configuration menu title -> Manage Local Users...

and added johndoe@rainbow.com using a specific "Mail Password" and "APOP Secret".

I have installed Mozilla Thunderbird.


Here is what's not working:

  1. When I send an email to johndoe@rainbow.com from Magento's forgotten password recovery in the admin panel, I don't see it in Mercury? What should I do?

  2. In Mozilla Thunderbird I see Tools -> Account Settings... and Tools -> Options... as these seem to be the places where I configure Thunderbird. I have inserted my email address under Options... and set the server name to rainbow.com in Options... -> Server Settings.

    However I don't see where I insert the "Mail Password" and "APOP Secret" in Thunderbird. In fact, I do not see anywhere any configurable settings for POP3; I only see IMAP configuration settings. So when I try to send mail via Thunderbird, I get the following error message:

    "An error occurred while sending mail. The mail server responded: Service not available, closing channel.. Please verify that your email address is correct in your Mail preferences and try again."

    All I have in my inbox is a message saying "Welcome to Pegasus Mail!" from David Harris. I thought Prgasus was a client like Thunderbird, and that Mercury (not Pegasus) was the mail server, where have I gone wrong?

  3. When I close the window entitled Mercury/32 which I opened via the Admin button in the Mercury row in XAMPP Control Panel v.3.2.1, by clicking the x on the upper right hand corner of the window, Mercury crashes with the messages:

18:46:55 [mercury] Status change detected: stopped 18:46:55 [mercury] Error: Mercury shutdown unexpectedly. 18:46:55 [mercury] This may be due to a blocked port, missing dependencies, 18:46:55 [mercury] improper privileges, a crash, or a shutdown by another method. 18:46:55 [mercury] Press the Logs button to view error logs and check 18:46:55 [mercury] the Windows Event Viewer for more clues 18:46:55 [mercury] If you need more help, copy and post this 18:46:55 [mercury] entire log window on the forums

Why should closing the admin window make Mercury stop, and then crash in the manner?


Conclusion:

I am trying to use Mercury to test email features before going live, but am unable even to send a simple email to myself and view it in Thunderbird. Any help with this is sincerely appreciated.

share|improve this question
add comment

1 Answer 1

i encountered problem with email sending with XAMPP installed mail server Mercury. During installation there missed obligate folder QUEUE and sending process breaking. Just create this folder in mercury directory and all will be fine. Thanks to this post http://community.pmail.com/forums/thread/38814.aspx

share|improve this answer
    
note to myself it is QUEUE not QUEQUE :) –  max4ever Jan 18 at 11:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.