Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I purchased a new 4TB HDD and put it in an enclosure for external use. I formatted that HDD using the disk management tool (as GPT rather than MBR) and assigned a drive letter to it. I was able to use the HDD just fine. I found out, however, that on the box of the enclosure was listed "supports hard drives up to 3 TB." I was kind of apprehensive about continuing to use this enclosure, so I got a new one which supports 4TB hard drives.

However, with this new enclosure, I now cannot see the drive in Windows Explorer. When I go to disk management, I can see it listed as a Healthy GPT Protective Partition. When I right-click it, though, the only option is "Help."

Here's what I've tried:

When I use the diskpart command line tool, I am able to see the disk with list disk. However, list volumes on the disk returns "There are no volumes." list partition returns

Partition ###   Type           Size      Offset
-------------   -------------  --------  ------
Partition 1     Primary        3726 GB   4096 B

I also tried using the program testdisk. I tried the following: For Please select the partition table type, I chose [EFI GPT]; I then chose Analyse, then got Bad GPT partition, invalid signature. Trying alternate GPT. invalid signature., then did Quick Search when it said Try to locate partition. It located an MS Data partition, and I was able to explore it and copy files from it.

So why can't I see it in Windows Explorer, and why can't I assign a drive letter to it? And why is it not associated with a volume in the diskpart utility?

EDIT: Here are the products I have referred to:

The original enclosure which supports up to 3 TB: http://www.amazon.com/Sabrent-3-5-Inch-Aluminum-Enclosure-EC-3US35/dp/B003CJQ69A/ref=pd_sim_sbs_pc_5

The new enclosure specifically tested with 4 TB drives (also has a fan): http://www.amazon.com/StarTech-com-3-5in-SuperSpeed-Drive-Enclosure/dp/B003F5NS9W

The 4 TB hard disk drive: http://www.newegg.com/Product/Product.aspx?Item=N82E16822178338

share|improve this question
1  
The enclousure its likely treating the disk differently. Have you considered reformatting the drive while its in the new enclousure? –  Ramhound Oct 11 '13 at 18:40
    
That's a totally viable option, but I would like to know if this is correctable without formatting though, especially if something like this happens in the future (perhaps with another enclosure, etc), and I don't have a means of copying the files from it. –  Intredasting Oct 11 '13 at 18:48
    
In order to explain how to get around that, we have to determine, the reason it happen. Lets start with specific product information. –  Ramhound Oct 11 '13 at 18:52
    
Does it work If you remove the disk from the enclosure and connect it directly to the computer (either directly to the logic board or with a usb adapter)? –  Colyn1337 Oct 11 '13 at 18:59
    
It is a laptop computer, so the first option is not really viable. And I'm not sure what you mean by USB adapter, other than an enclosure. Also, I'll add in the product information above. –  Intredasting Oct 11 '13 at 19:35

3 Answers 3

Some enclosures have a 2.2TB limit simply because the electronics and firmware (USB to SATA bridge) can only address 32-bit LBAs.

Even enclosures that support 48bit LBA, doesn't necessarily support HDDs larger than 2.2TB, simply because the rest of electronics doesn't support 48bit LBA. If you want to be on a safe side, look for an enclosure with 48bit LBA support that is explicitly tested by the manufacturer for 4TB HDDs.

Also avoid enclosures with JMicron chip as it is known by poor performance

share|improve this answer
    
Could you expand a bit on how that affects whether he can see his data when swapping into a larger enclosure? –  Colyn1337 Oct 11 '13 at 19:02
1  
Thanks, but this does not really answer my question. The enclosure did not have a 2.2 TB limit; it supports "up to 3 TB" drives, as stated on the box. I was actually able to see the whole 4 TB, but I was just apprehensive about the fact that the enclosure was not tested with 4 TB drives. –  Intredasting Oct 11 '13 at 19:33
    
I maybe didn't understand the point of question quite well. What I have experienced is that enclosures might have issues depending on the chipset and firmware used. I'm not sure is there a rule, but on the same MoBo with 2 different USB controllers and I was able to use the disk with one and not with another. Also, I have had a chance to see the same behavior with eSATA and IEE1394 enclosures. I'm talking about 4TB HDDs. So only that I was able to conclude is that there is some electronics or firmware incompatibility. This is just an experience and nothing else –  Nikola Dimitrijevic Oct 11 '13 at 20:18
    
To add to this: To circumvent the MBR limit, some enclosures use a horrendous technique: They emulate 4K sectors. This causes major issues when accessing the disk without the enclosure. Because, obviously, all addresses everywhere are wrong. –  Daniel B Apr 11 at 23:46

You will probably have to update the disk signature. There's a tutorial here http://www.howtohaven.com/system/change-disk-signature.shtml but it's a somewhat risky procedure. You may need to use "diskpart" possibly to configure a new signature.

share|improve this answer
  1. You need to use your old external case and access the drive.

  2. Delete the partitions.

  3. 'Convert to MBR'

  4. Then you should be able to put the drive in your new case and access it there.

  5. 'Convert to GPT' again because MBR only supports up to 2TB and you have a 3TB drive.

I found this old thread because I just had the same problem.
I suppose you can try accessing the drive in some other way like internal SATA or borrow a hard drive dock, if you don't have your old case any longer, and follow steps 2-3.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.