Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently successfully installed Arch Linux in VirtualBox, for the first time. I want to install FVWM, so I installed X Server, and then ran pacman -S fvwm. It says that fvwm has been installed, but the terminal still stays there and there is no windowing. I know I am probably doing something stupid, but I'm not sure what. Please tell me what I am doing wrong.

Update: I installed GDM. When I select "fvwm" in the menu and enter my password, the screen turns black, several console messages with a green "okay" status to the left appear, the screen goes black again, and then it turns gray and returns to the login screen.

Thanks, cloudcoder2000

share|improve this question
    
What happens if you run startx? If that does not work, post your /usr/bin/startx file. –  terdon Oct 12 '13 at 3:28
    
@terdon: When I run startx, the screen goes black and resizes, but then nothing happens and ctrl-c doesn't work. I have reboot through the virtualbox menu. –  troglodite Oct 12 '13 at 20:50
    
@terdon: I see the /usr/bin/startx and I am able to access it through nano, but I am not sure how to post it since I just installed Arch. –  troglodite Oct 12 '13 at 20:50
    
Just check if there is an exec fvwm line at the end, there shouldn't be, but just in case. Try what MariusMatutiae suggests, if that fails, just add exec fvwm to the end of startx. Oh, and Ctrl+Alt+Backspace should let you exit after you've run startx. –  terdon Oct 12 '13 at 23:24
    
Neither of the suggestions worked. Also, when I run startx still goes black, and Ctrl+Alt+Backspace doesn't work. I get the error xauth: timeout in locking authority file /home/cloudcoder2000/.Xauthority. It pops up 3 times, then I see several output messages, and then finally the screen goes black. –  troglodite Oct 13 '13 at 23:45

2 Answers 2

up vote 2 down vote accepted

The problem here is that your $HOME directory is owned by root (the OP pasted this in chat):

$ ls -l /home 
total 20 drwxr-xr-x 2 root root 4096 Oct 13 18:38 cloudcoder2000 drwx------ 2 root root 

So you don't have write access to your $HOME which means that X cannot create a $HOME/.Xinit file and that is giving you the error you see. The following commands should fix it:

sudo rm ~/.Xauthority
sudo chown cloudcoder2000:cloudcoder2000 ~/

You can now add this line to your ~/.xinitrc (this command will create the file if it does not exist):

echo "exec fwvm" >> ~/.xinitrc

Now, running startx should start an fwvm session.

share|improve this answer

The proper way to start FVWM in Arch is to add the line "exec fvwm" to your .xinitrc file, then restart the VM. Did you try that? Or: you should see it in the "Sessions menu" at login, if you use either kdm or gdm (I think...). Did you check this

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.